Bug? Pascom Client 47.R161 wählt Prefix aus Journal nicht mit

Hi.

In der 18.04 hat sich wohl das fehlen der Standart-Amtsholung eingeschlichen. Wichtig ist das Ihr nach Änderung der Standart-Amtsholung die vorgeschlagenen Jobs durchlaufen lässt (ggf muss auch der XMPP Server neugestartet werden).
Wichtig ist also das folgende 3 Einstellungen zueinander passen (bei Änderungen das Telefoniekonfig anwenden bitte nicht vergessen):

  • Appliance->Dienste: Telefonie “Standard-Amtsholung”
  • Gateways->Ämter: Basisdaten “Präfix eing. Nummer”
  • Gateways->Ämter: Ausgehende Rufe “In-Prefix”

Grüße,
Steve

Hallo,

ich habe jetzt in der Standard-Amtsholung eine Null eingetragen. Nun funktioniert es so wie erwartet. Man muss im Client die zusätzliche Amtsholungs-Null auch nicht mitwählen. Ich denke, dass ist so gewollt.

Nur noch zwei Fragen zur Auswirkung:

  1. Wie verhält sich das nun, wenn man keinen Soft-Client, sondern ein “richtiges” Telefon verwendet? Muss man dort die Null dann mitwählen? Und wird diese auch bei eingehenden Rufen der Nummer vorangestellt, so dass ein direkter Rückruf der angezeigten Nummer funktioniert? Ich kann das leider nicht testen, da ich (noch) keine Hardware hier habe.

  2. Wenn ich es richtig verstehe, wird ja nun nach extern immer automatisch eine Null vorgewählt. Was passiert nun, wenn ich ein weiteres Amt anlege, um damit eine Kopplung zu einer anderen Telefonanlage an einem anderen Standort durchzuführen. Ich wollte das über ein anderes Prefix abhandeln. Also so, dass ich dann “Prefix+Durchwahl in der anderen Anlage wähle”.Geht das dann trotzdem?

Vielen Dank und Gruß
Stephan

Hallo,

und wie sollen dann diese 3 Einstellungen genau richtig gesetzt werden, wenn die Standard-Amtsholung auf 0 gesetzt wird?
Ist es dann richtig, dass im eingehend Amt der Präfix auf 0 und Ausgehende Rufe auch der in-Prefix auf 0 steht?

Wenn ich es so einstelle, dann geht es nicht, gleiches Problem, auch nach XMPP neustart.

Viele Grüße
Michael

Hallo Michael,

entweder an allen 3 Stellen die 0 oder eben alle 3 stellen leer lassen. Wenn es für neue Journaleinträge oder reguläre Anrufe weiterhin scheitert müsste man tiefer in das debugging einsteigen, das ist an dieser Stelle leider schwierig.

@sfietzek:
Zu 1.: Ja hier müsste man dann am Telefon dennoch die 0 mitwählen. Ist das nicht gewollt dann an allen 3 Stellen nichts eintragen, dann kann an jeder Stelle “natürlich” gewählt werden.

Zu 2.: es wird dann nach außen keine 0 mit gewählt, der In-Prefix wird ja abgeschnitten und dient nur zur “Amtsholung innerhalb der Anlage” also zur Bestimmung ob und welches Amt verwendet wird. Wenn keine interne Durchwahl angerufen wird, dann wird jedoch immer versucht eine geeignete ausgehende Regel zu suchen, dass ist auch der Grund warum man die 0 überall weglassen kann.
Welches Amt verwendet wird, wird über die ausgehenden Regeln bestimmt. Lies dier dazu bitte hier etwas weiter unten Regelgültigkeit (Best match) durch:
https://www.pascom.net/doc/de/trunks/rules/#ausgehende-rufe

Grüße,
Steve

Hallo,
wie konfiguriere ich den Client denn für verschiedene Ämter?

Amt A geht mit 0, Amt B geht mit 1 raus. Kommt ein Anruf über Linie B setzt die Anlage bei einem Eingehenden Anruf (1)0171… vor die Nummer und ich kann direkt über die Linie auch zurück rufen. Gleiches bei Amt A, (0)0171…
Im Client allerdings wird mir immer 0049171… angezeigt, egal welche Linie, an den Hardware Telefonen Funktioniert es aber wie gewollt.
Durch " Appliance->Dienste: Telefonie “Standard-Amtsholung” = 0 " wird die 0 im Client ja voran gesetzt und ein Rückruf aus dem Journal funktioniert für Amt A… aber ich kann nicht über das Amt B mit der 1 Telefonieren, die 0 wird ja automatisch voran gesetzt. Setze ich “Appliance->Dienste: Telefonie “Standard-Amtsholung” = leer” hat er mir 0049 vor die Nummer im Journal gehängt… also 00490049171… Problem ist das im Client journal, anders als bei den Telefonen die Amtsholung nicht mit im Journal steht. Im Telefon habe ich also richtig 00171… im client 0049171…, bei einem Rückruf fehlt die 0, aber auch die 1, mit Standard Amt wird dann eventuell das falsch Amt gewählt ;).

18.05 und neuste client Version.

Grüße Malte

Habe das selbe Problem wie the_muck.

Wir evaluieren gerade die Pascom 18.09. als neue TK-Anlage. Um nicht alle Nebenstellen auf einmal umstellen zu müssen, ist die alte Anlage per weiteren SIP-Amt verbunden. Die Amtholung dafür ist 3.

Ich bin also gezwungen “Standard-Amtsholung” leer zu setzen. In den Ämtern aber

  • Gateways->Ämter: Basisdaten “Präfix eing. Nummer” auf 0 bzw 3
  • Gateways->Ämter: Ausgehende Rufe “In-Prefix” auf 0 bzw 3

Nach erfolglosen Versuchen die 0 mit unterschiedlichen Einstellungen im Amt reinzumoggeln und dabei einem Auge auf die asterisk Konsole, komme ich zum Schluss das hier ein Bug im Client vorliegt.
In den Details eines Anrufs im Journal des Clients ist der Prefix zu sehen. Dieser müsste vom Client verwendet werden, was er aktuell (Version: 53.R453_4de72d3) nicht tut.

Eine TK-Anlage bei der man nicht aus dem Journal ohne manuelle Nachbearbeitung der Nummer wählen kann, läßt sich schlecht verkaufen.

Hallo @bbaumer,
um zu entscheiden welches Amt für einen Anruf aus dem Journal verwendet werden soll, muss in den Ämtern unter “Ausgehende Rufe” für die jeweiligen Regeln die Spalte “Im Client anzeigen” auf “Ja” gestellt werden.
Nach einem Neustart des Clients solltest du diese Feld dann über dem Dial Pad zur Auswahl haben. Ansonsten wird immer die (in deinem Fall nicht vorhandene) Standardamtsholung verwendet.

Besten Gruß
Sebastian

Hallo @Sebastian_F,

danke für die schnelle Antwort und den Hinweis auf die Auswahl des Amts im Client.

Am Problem ändert dies allerdings nichts.
Ich rufe meine Nebenstelle von außen an und nehmen das Gespräch an. Im Journal steht
0049721******* (Prefix 0). Nach meinem Verständnis korrekt.
Versuch ich nun aus dem Journal zurückzurufen, hängt der Client die 0 nicht vorne an.
Die Anlage schneidet die 0 weg (049721***) und interpretiert das als nationale Nummer. Diese Nummer gibts es nicht und im Journal landet nun 004949721***

Hallo,

auch wir haben das Problem immer noch, dass eine führende 0 zu viel in der Anrufliste steht…

AUch sämtliche Updates die in den letzten Moanten waren habe nix gebracht, laut Support passen die Einstellungen wohl auch…

Wäre schön, wenn das endlich richtig gehen würde…

Hallo zusammen was steht denn unter Dienste Telefonie als Präfix drinn?

Verstehe ich nicht das Problem. Wenn du als Präfix zum rauswählen die 3 hast dann solltest du unter Dienste Telefonie auch die 3 einstellen dann kann das der Client auch wählen nicht betreffen tut das natürlich die alten Einträge im Rufnournal da es da ja noch falsch war.

Gruß Markus

Die Einstellungen habe ich bereits oben genannt.
Die Standardamtsholung kann ich nicht setzen, da die Gespräche dann immer über das entsprechende Amt gehen. Das gilt insbesondere für die Telefone.

Hallo,
das ist vermutlich das selbe Problem wie hier:


und wird mit der 18.10 behoben.

Gruß Jonas Plaum

Hallo,

gerade das Update auf die 18.10. durchgeführt.

Das Problem besteht leider weiterhin.

Hallo @bbaumer,
der vorher erwähnte Bug wäre nur aufgetreten, falls die Nummer aus einem verbundenen Telefonbuch (Outlook, Datev, Android, Apple) aufgelöst worden wäre. Ich nehme an das war bei dir aber nicht der Fall? Falls doch: Sind auch komplett neue Journaleinträge betroffen?
Es wäre nett, wenn du mir ein paar Screenshots deiner Ämterkonfiguration (“Basisdaten” und “Ausgehende Rufe”) sowie den Client (auf dem der ausgewählte Prefix über dem Dialpad zu erkennen ist) senden könntest.

Besten Gruß
Sebastian

Hallo @Sebastian_F,

oben ist bereits alles beschrieben.
Ich denke eine TeamViewer-Session wäre sehr hilfreich.
Wärst du dazu bereit?

P.S: Wir sind zwischenzeitlich zahlender Kunde :slightly_smiling_face:

Hallo,
ich glaube wir haben vorher aneinander vorbeigeredet. Das momentane (gewollte) Verhalten mit den im Client auswählbaren Amtsholungs-Prefixe ist wie folgt:
Wenn “auto” als Prefix im Client ausgewählt ist wird immer (egal welches Prefix im Journal steht) die Standardamtsholung gewählt (unter Dienste -> Telefonie) was in deinem Fall also nicht funktioniert.
Du muss also immer das Dropdown im Client auf das richtige Amt umstellen.

Besten Gruß
Sebastian

Hallo,

die Standardamtsholung funktioniert, denn sie ist leer. Ansonsten könnte ich die Teilnehmer an einem anderen Amt, in diesem Fall die alte TK-Anlage, nicht erreichen.
Für die Telefone benötige ich im Telefonbuch die führende 0 bzw 3.
Wähle ich im Client das 0-Amt, komme ich nicht mehr an das 3-Amt. Die Wahl aus dem Journal funktioniert damit.
Allerdings benötigt man für die Telefone und damit das Telefonbuch die führende 0 bzw 3. Zudem funktioniert das so auch mit den Telefonen.

Die Anlage normiert die Telefonnummer des Anrufers ins internationale Format. Dies landet so dann im Journal ohne Prefix z.B. 0049 123 465. Versucht man diesen Eintrag zurückzurufen wird 0049 49 123 456 draus und damit ungültig.

Ich denke der Client sollte bei Auto das Prefix des Amtes mitwählen, falls die Standardamtsholung leer ist. Bei der Auswahl eines konkreten Amtes dann dessen Prefix verwenden.

Was ist der Anwendungsfall für die Auswahl eines Amtes durch den Benutzer im Pascom Client?

Über eine Antwort auf meine Fragen und den Vorschlag würde ich mich sehr freuen.

Aktuell sehe ich die Pascom bei mehreren Ämtern und gemischten Einsatz von Telefonen und dem Desktop-Client als eingeschränkt nutzbar an.

Das ist Deine Erwartung, was passieren müsste bei ‘Auto’. Das tatsächliche (und gewollte) Verhalten bei Auswahl von ‘Auto’ ist aber, wie von @Sebastian_F beschrieben. Es wird das vorweg gewählt, was unter Dienste-Telefonie als Standard-Amtsholung eingestellt ist.

Es gibt Fälle, wo man für abgehende Anrufe eine abweichende Rufnummer (oder auch anonym) anrufen möchte. Deshalb kann man im Client einstellen, über welches Amt der Anruf getätigt werden soll. Dahinter sind dann entsprechende ausgehende Rufregeln definiert. Ein anderer Anwendungsfall ist im Callcenter zu finden. Für abgehende Anrufe soll dort ein bestimmter Account genutzt werden, damit die richtige Nummer beim Ziel angezeigt wird.

Deshalb ist es ja auch pro Amt einstellbar.

Bsp.:
Amt A ist mit einem Inpräfix von ‘0’ angelegt. Ausgehende Rufregeln verwenden ebenfalls diesen Präfix.
Amt B ist mit einem Inpräfix von ‘3’ angelegt. Ausgehende Rufregeln sollten nun ebenfalls diesen Präfix bei dem Amt eingestellt haben.

Wenn nun ein Anruf eingeht, sorgt der Inpräfix im Amt dafür, dass in den Anruflisten der Hardware-Telefone der passende Präfix in den Anruferlisten gesetzt wird, damit man beispielsweise aus einer Liste verpasster Anrufe über den passenden Account den Rückruf einleiten kann.

Mit dem Telefonbuch hat das als quasi nix zu tun. Das Telefonbuch der Telefonanlage wird immer ohne irgendwelche Amtskennziffern gepflegt.

Aber wie @Sebastian_F ebenfalls schon vorgeschlagen hat, poste doch einfach mal die entsprechenden Screenshots und beruf’ Dich nicht darauf, dass ja schon alles beschrieben sei. Häufig sagt ein Bild mehr als tausend Worte. Deshalb gibt es ja auch Instagram und keine Textmessanger mehr :wink: Und sicherheitsrelevante Infos wie Passwörter, Benutzername oder Rufnummern kannst Du ja schwärzen.

LG
Michael