Connector Telefonbuch via CSV (HTTPS, insecure)

…oder wie gebe ich Parameter an curl weiter?

Hallo,

habe einen Connector Telefonbuch via CSV in einer 18.02 eingerichtet. Hier läuft ein Pre-Script im cronjob um die CSV-Datei per curl vom Server zu holen, etwa in der Form “curl -k https://server/tbook.csv /tmp/tbook.csv”.

Seit dem Upgrade auf 18.06 (vmtl. bereits seit Einführung des “Fetch from URL” Typs) funktioniert der Job nicht mehr. Der Connector wird nach dem Upgrade als Typ “Manual Upload” angezeigt, dies funktioniert dann natürlich nicht mehr automatisch.

Habe nun einen neuen Connector mit Typ “Fetch from URL” angelegt und möchte curl aber gern das “-k” (–insecure) mitgeben. [Wird denn überhaupt noch curl dazu genutzt?]

In der URL wird der Parameter ignoriert bzw. führt es nicht zum gewünschten Ergebnis.

Auf der Console (auch im lxc container der Instanz) wird das tbook.csv geladen.

Gruß,
Rapha

Hallo Rapha,

ich bin mir zwar nicht zu 1000% sicher, aber mit der Einführung von “Fetch from URL” funktionieren die alten Connectoren nicht mehr und ich meine auch, die Begründung ist gewesen, dass man mit Fetch from URL alle Anwendungsfälle abdecken kann, es dreht sich halt nur die Richtung.

Während Du beim Import mittels curl ja erst noch die Datei abholen und dann auch noch ggf. in den richtigen Container kopieren musstest, kann man nun ja ganz einfach jede beliebige URL nutzen und die Pascom holt die Datei da einfach ab.

Somit müsstest Du also im Prinzip Deine Quell-Datei auf irgendeinen internen oder externen Webserver Deiner Wahl kopieren und um den Rest kümmert sich dann die Pascom. Eigentlich ganz schick gemacht und funktioniert ziemlich gut.

Aber vielleicht hast Du ja auch einen speziellen Grund, weshalb Fetch url für Dich nicht in Frage kommt.

Gruß
Michael

Hallo Michael,

die Richtungsumkehr ist mir aufgefallen, das sollte auch nicht das Problem sein. Die URL bzw. das Dokument lässt sich ja auch abholen, allerdings nur per HTTP oder HTTPS mit gültigem (und in der pascom bekanntem) Zertifikat.

smb:// ist sicherlich auch möglich, hier bekomme ich aber immer Anmeldefehler (Windows-Server mit Domänen-User).

Mein Webserver lässt nur HTTPS Verbindungen zu, darum müsste das Zertifikat auf die pascom oder aber curl kann mit --insecure aufgerufen werden um die Zertifikatgültigkeit zu ignorieren.
Hier dann die Frage ob dies möglich ist oder lässt sich das Zertifikat (updatesicher) auf die pascom legen?

Gruß,
Rapha

Meiner auch nur, allerdings verzichte ich auf mittlerweile überall, wo erforderlich auf self signed Zertifikate. Dank let’s encrypt ist das ja in vielen Fällen überhaupt kein Problem mehr und Du musst nicht zwingend Zertifikate auf der Pascom hinterlegen. Aber auch hier wird es Fölle geben, wo das erforderlich sein mag.

Dazu msuss dann Pascom mal was sagen.

Gruß
Michael

Hallo zusammen,

wir verwenden hier nicht CURL auf der Kommandozeile, sondern die in PHP integrierte libcurl. Eine Option zum deaktivieren der Zertifkatsprüfung ist hier noch nicht eingebaut.

Ich habe ein Ticket dazu eröffnet, wir diskutieren das Thema mal.

Grüße,
Jan

1 Like

Ab 18.08 funktioniert es, man muss im Connector entpsrechend Ungültige Zertifikate ignorieren auf Ja setzen.

Vielen Dank und Gruß,
Rapha