Externe Rufnummer wird auf Telefon nicht angezeigt

Vielleicht schilderst Du nochmal im Detail den exakten Aufbau und das konkrete Problem. Eventuell gibt es ja einen alternativen Workaround. Ansonsten bleibt nur warten.

Ankündigungen mit Versionsnummern sind mit Vorsicht zu genießen, es kann ja immer mal ein dringender Bug kommen, der ein Release notwendig macht. Natürlich können wir dann keine Nummer “auslassen” sondern das eigentlich geplante Feature verschiebt sich halt numerisch, aber nicht zeitlich, nach hinten.

Hallo Thomas,

vielen Dank für deinen Post. Mittlerweile habe ich mich auch wieder beruhigt…, sorry für meine Reaktion!

Das ursprüngliche Problem:

Bei einem externen Anruf der intern transferiert wird, wird nicht die Rufnummer des externen Teilnehmers am Yealink signalisiert, sondern die interne Rufnummer. Wenn also ein Blindtransfer gemacht wird, meldet sich der angerufene interne Teilnehmer mit “Hallo…”, weil er meint ein Kollege ruft ihn an. Doof!

Dann hatte ich wegen eines Fixes hierzu in diesem Thema angefragt und folgendes in die SIP Optionen der Endgeräte eingetragen (was ich von dir bekommen habe):

endpoint/trust_id_inbound=yes
endpoint/trust_id_outbound=yes
endpoint/send_connected_line=yes
endpoint/rpid_immediate=yes
endpoint/send_rpid=yes
endpoint/send_pai=yes

Nun wurde das beschriebene Problem mit der Rufsignalisierung behoben, aber dafür passiert nun folgendes am Yealink:

Aus der Wahlwiederholungsliste funktioniert das wählen nicht mehr, weil die Amtsnull scheinbar fehlt. Diesen Fehler gab es schon einmal und er war auch durch eine SIP Optionen zu fixen, wurde dann in einer Pascom Version auch gefixt.

Weiterhin steht beim A Teilnehmer, wenn er intern jemanden anruft, erst die Rufnummer des Teilnehmers und dann “int-76”. Die interne Rufnummer ist aber nicht die 76.

Noch Fragen?

LG THOMAS

Also, ich habe die Optionen nun entfernt, dann muss der Kunde halt mit dem eigentlichen Fehler leben, bis es gefixt ist.

Schönes Wochenende!

LG THOMAS

Hi @EDV-Service

Dein Problem wurde in der ab heute verfügbaren Version 19.05 repariert.
Der Rollout in der Cloud wird, wie immer, ein paar Tage in Anspruch nehmen.

Gruß,

Thomas

Wie lange sind denn “ein paar Tage” ?

Haben hier einen Kunden mit der Version 19.04 (umgestellt vorgestern von 18 auf 19.04), der das gleiche Problem hat.

Außerdem noch einige Kunden mit der 19.03, die anscheinend auch nicht geupdated werden.

Gruß
Conrad

Der Rollout läuft und es werden alle 19.x Instanzen hochgezogen. Auch heute Nacht gibt es wieder eine Welle an Updates.

Gruss,

Thomas

Ich freu mich!

LG THOMAS

Da mir ein Kunde mitgeteilt hat, das er dieses Problem noch hat, habe ich mir auf zwei verschiedenen 19.05er Anlagen zwei Yealinks provisioniert. Auf beiden Anlagen verhält es sich gleich.

Es wird keine externe Rufnummer auf dem Telefondisplay angezeigt, nur die interne.

Ich habe auch schon ein Ticket eröffnet, aber ich dachte man kann das ja auch zusätzlich hier im Forum diskutieren.

LG THOMAS

Ich bekam heute auch eine Info von einem Kunden mit dem Problem. Habe mir das nicht näher angesehen, wollte das nur mal posten, damit erkennbar wird, dass es nicht nur vereinzelt auftritt.

Okay, dann ist das Problem scheinbar grundsätzlich noch nicht aus der Welt. Danke für deine Rückmeldung!

LG THOMAS

Kann die Entwicklung zur Behebung dieses Problems eventuell etwas sagen?

LG THOMAS

Hallo @EDV-Service,

ist das bei euch in jedem Fall reproduzierbar (auch mit der Standard-Basiskonfiguration und auf Werkseinstellungen zurückgesetzt)? Wie genau läuft der Anruf dann ab und sind eventuell irgendwelche (vorher/nachher) Aktionen involviert?
Welche Endgeräte mit welcher Firmware sind denn betroffen?

Danke und besten Gruß
Sebastian

Hallo Sebastian,

hatte ich vor zwei Wochen bereits via Ticket 5929629 mitgeteilt, da es dort aber nicht voran geht (und mich der Kunde nervt), wollte ich an dieser Stelle im Forum nachhaken…

LG THOMAS

Hallo Thomas,
danke, das funktioniert anscheinend nur bei bestimmten Geräten/Konfigurationen/Firmwares nicht. Wir sehen uns das nochmal genauer an - bei Neuigkeiten melde ich mich.

Besten Gruß
Sebastian

Und in welchen funktioniert es?

Wenn ihr jetzt die 19.06R ausrollt, habe ich sorge das mit dem Update nachher bei anderen Instanzen auch dieses Problem auftaucht, was auf jeden Fall nicht passieren darf!

LG THOMAS

Hallo,

wir werden Deinen konkreten Fall heute nochmals bei uns nachstellen und detailliert debuggen.

Bitte noch etwas Geduld.

Gruß,

Thomas

Hallo @EDV-Service,
der SIP Traffic sieht bei uns in Ordnung aus. Sobald der Transfer an das Zielgerät passiert, gibt es ein SIP UPDATE mit P-Asserted-Identity: <sip:009912345678@pascom0> und Remote-Party-ID: <sip:009912345678@pascom0>;party=calling;privacy=off;screen=no

Wichtig dabei ist, dass auf dem Ziel-Yealink folgendes Setting provisioniert ist:
account.1.cid_source = 2
Das ist zwar bereits Teil unseres Standard-Templates für Yealink, aber bei angepassten Basiskonfiguration fehlt dies eventuell. In der GUI findet sich das unter Konto -> Erweitert -> Quelle Anrufer-ID.
Gerne können wir auch über unseren Support einen Termin ausmachen um das näher zu debuggen, falls das oben genannte nicht anschlägt.

Besten Gruß
Sebastian

Hallo Sebastian,

bei mir ist die Option bereits in der Basiskonfiguration enthalten und im Telefon steht “Quelle Anrufer ID” “PAI-VON”.

Da es jetzt nicht funktioniert, werde ich mich morgen im Support melden.

Danke für deine Antwort!

LG THOMAS

Hinweis, falls sonst noch jemand über dieses Problem fällt: Es hängt stark davon ab wie genau am Gerät transferiert wird. Wir konnten das Problem aber über folgende Settings in der Basiskonfiguration lösen:

account.1.cid_source = 2
transfer.semi_attend_tran_enable = 0
transfer.blind_tran_on_hook_enable = 0

Ähnliches lässt sich übrigens auch auf Grandstreams beobachten. In dem Fall hilft:

# Caller ID Display. 0 - Auto, 1 - Disabled, 2 - From Header. Default is 2
# Number: 0, 1, 2
# Mandatory
P2324 = 2

Besten Gruß
Sebastian

Dieses Problem besteht bei uns auch, mit SNOM D765 / D725 Telefonen.
Gibt es auch hier eine Lösung?

Beim Pascom Client wird die richtige Nummer angezeigt, nur nicht im Diyplay vom Telefon.