Gehende Rufnummer bei einer Weiterleitung aus einer Rufgruppe inkorrekt

Hallo,

wir haben in einer Rufgruppe eine Weiterleitung aktiviert unter Extern/Nachher als Abwurf mit main,0VWRufnummer,1

Wenn ein Anruf über die Rufgruppe nun eingeht, wird dieser auf die Rufnummer weitergeleitet, allerdings kommt als Rufnummer die NUmmer der Pascom und dahinter die Nummer das ANrufers.
Es sollte aber nur die Nummer des Anrufers übermittelt werden.

Für Umleitungen habe ich bereits in Ämter unter dem Provider (Peoplefone) unter Ausgehende Rufe die Weiterleitung mit ${CALLERID(num)} hinzugefügt.

Anlage ist die 18.07 Cloud.

Wie kann ich das einstellen, dass nur die Anrufernummer übermittelt wird?

Danke im voraus!

Michael

Hallo @M.Wimmer,

dazu muss A) beim Provider CLIP NO SCREENING aktiv sein - sonst überbügelt der das immer mit der Stammrufnummer und B) im Amt die richtige ausgehende Regel gesetzt sein.

Diese Regel gibt es als Vorlage. Einfach “Hinzufügen > Rufweiterleitung” bei den ausgehenden Regeln im Amt wählen.

LG
Mathias

Hallo,

Danke für die schnelle Antwort

Bei Peoplefone ist clipnoscreening aktiv und die Regel unter Ämter ausgehend ist auch gesetzt (habe ich bereits geschrieben gehabt). Es geht leider trotzdem nicht, was kann ich noch tun?

Viele Grüße
Michael

Hallo Michael,

dann greift die Regel aus irgendeinem Grund nicht. Das System arbeitet nach Bestmatch aus Quelle und Ziel und der Prefix muss passen. Evtl. passt eine andere Regel “besser” und wird daher verwendet? Der Trick ist eigentlich das _XXXX. als Quelle. Dadurch gilt die Regel nur für Rufumleitungen. Denn da ist die Quelle länger als 4 stellen, z.B. die externe Handynummer…

Du kannst auch auf der Asterisk CLI zusehen was passiert.

LG
Mathias

Ich hatte das Problem bei Easybell und die Rufregel verändert. Kann ich dir morgen nachreichen.

Hi!

Versuche bei der Rufregel mal folgendes:

Quelle: _XXXX.
CID Nummer: ${CALLERID(num):1}

Würde mich über Feedback freuen!

LG THOMAS

Hi,

für Peoplefone kenn ich die Nummernformatierung gerade nicht, wichtig ist jedoch wenn die Amtholungs-Null (default) verwendet wird diese wieder Wegzuschneiden, wie von Thomas beschrieben.
In seltenen Fällen akzeptiert der Provider aber auch das nicht (obwohl er eingehend die Nummer genau so signalisiert hat) und man muss die Nummer um führende 0-en bereinigen oder 00 in + konviertieren oder andere abstruse Dinge (wenn man die Durchwahlen des Trunks signalisiert bekommt funktioniert i.d.R. das hier verwendete Nummernformat).
Eine weitere Fehlerquelle kann sein das die Nummer nicht in den geforderten Headern (FROM,PAI oder PPI beispielsweise) steht. Das wird für trunkzugehörige Nummern u.U. tolleriert aber nicht mehr wenn man andere Nummern versucht zu signalisieren. Manche provider möchten im PAI (p-asserted-identity) explizit eine accountzugehörige Nummer und im PPI (p-preffered-idenity) dann die zu signalisierende Rufnummer.
Unterstützt der Provider direkte Weiterleitung ergibt sich das Problem i.d.R. gar nicht, da hier nur das neue Ziel für den Provider relevant ist.

Kurzum mit dem Beispiel von Thomas wird es vermutlich bereits funktionieren (da die eingehend hinzugefügte 0 wieder weggeschnitten wird).

Grüße,
Steve

Hallo,

wegen urlaub bin ich noch nicht dazu gekommen.

Der Kollege hatte es zwischenzeitlich mit einer anderen Regel gelöst, anstelle des_XXXX. hat er einen Stern gesetzt.

Jetzt habe ich aber das Szenario nochmal nachgestellt.
Mit

Quelle: _XXXX.
CID Nummer: ${CALLERID(num):1}

funktioniert es auch bei Peoplefone.
Vielen Dank an @EDV-Service

Viele Grüße
Michael