Kein Ton bei externem Gerät


#1

Hallo,
habe hier folgendes Problem mit der Mobydick v15.
Als Gerät habe ich ein externes Telefon angelegt und das einem Benutzer (zusätzlich zu seinem intern Telefon) zugewiesen. Bei eingehendem Ruf klingeln beide Telefone. Wird das Gespräch am externen Telefon entgegen genommen ist keine Kommunikation möglich, d.h. der eine hört den andern nicht.
Amt ist ein SIP-Trunk der Telekom, die Option progressinband=yes brachte keinen Erfolg.
Jemand noch eine Idee?

Besten Dank


#2

kann man vom ext Telefon normal wegrufen? Hört man hierbei auch etwas in beide Richtungen?

Würde mal auf ein NAT Problem tippen…


#3

Hallo @hw123,

ist auch der letzte Hotfix 15.11 implementiert? Und funktionieren Rufumleitung nach extern an sich auf Audio bezogen?
In einem der letzen Hotfixes hat sich das Verhalten wann im Dialplan der Progress() signalisiert wird geändert. Dadurch sollte sich das eigentlich bessern.

Grüße,
Steve


#4

@ Christian
Das externe Telefon funktioniert natürlich wie es soll…


#5

Hallo Steve,

wo sehe ich ob der letzte Hotfix installiert ist ? Der Updater sagt mir folgendes:

Available Packages

The package list shows the status of installed and new packages (modules) which are now available.

Important notice before performing an update:

Please read the release notes!
Have you performed a system backup? If not, do so now
The pascom server version available in pool is older than the one currently installed. Please visit my pascom and change the update channel.
Installed: 7.16.00.R
Available: 7.15.11.R

Gruss Jens


#6

Kannst Du im Commander (Weboberfläche) einsehen. Steht unten links! Ansonsten auch im Commander unter Informationen > Versionsinfo.


#7

Danke!

Also unten links steht bei mir 16.00 und unter Informationen - Paketversion auch überall 7.16.00 R

Gruss
Jens


#8

Hallo,

dann bist du auf den Falschen Channel mit der Lizenz du kannst nicht von 16.00 auf 15.xx Updaten
Wer hat das installiert? Der sollte auch den Channel im Portal umstellen können.

Gruß Markus


#9

Hallo @hw123,

du solltest den Updatechannel auf Current umstellen, dann bekommst du die 17.08 die den Hotfix enthält. Ansonsten müsstest du solange warten, bis die Stable Version (vermutlich dann 17.X) über deiner Version liegt.

Grüße,
Steve


#10

Hallo,

als installiert habe ich die Anlage letztes Jahr; seinerzeit die Current Version.
Keine Ahnung was das mit dem Update Channel auf sich hat aber den stelle ich wo um? Unter mypascom.net ?
Leider bekomme ich mit meinem Login dort eine alte Anlage von uns angezeigt die nicht mehr existiert.
Die jetzige haben wir von unserer Schwesterfirma übernommen…
Muss erst die aktive Lizenz an meinen Account gebunden werden damit ich hier die aktuelle Anlage sehe und den Updatechannel umstellen kann? Oder bin ich da völlig falsch?
Alternativ könnte ich die 17.08 frisch installieren, wäre natürlich mehr Aufwand…

Gruß
Jens


#11

Hallo Jens,

am besten den Support mit der Appliance ID anschreiben, dann können wir das klären. Aber ja my.pascom.net wäre die richtige Anlaufstelle um den Updatechannel zwischen LTS,Stable und Current zu ändern.

Grüße,
Steve


#12

Hallo Steve,
konnte den Updatechannel nun ändern und habe ein Update auf die 17.08 vorgenommen.

Schön ist das ich am externen Telefon nun Ton habe,

Irgendwas stimmt denoch nicht denn wenn ich den Teilnehmer anrufe der ein Snom an der Mobydick und eben das exteren Telefon zugewiesen hat dann klingelt das SNOM nur einmal und zeigt im Display “call completed elsewhere” an. Das externe klingelt weiter, der Anrufer hat den normalen Rufton. Es ist also nicht möglich eingehende Rufe am Snom anzunehmen…
Irgendeine Idee?

Gruss Jens


#13

Hallo Jens,

gibt es noch ein ausgehendes Script in Verwendung? Falls ja, das bitte mal rausnehmen (hier ist vermutlich noch ein Progress oder gar Answer, welches denn Call “stiehlt”).

Grüße,
Steve


#14

Hallo Steve,

nein es wurde kein Script angelegt bzw. eingebunden…

Gruß
Jens


#15

Hallo Jens,

dann müsste man sich das über den Support leider genau ansehen, im Vorfeld den zugehörigen Auszug aus der Asterisk CLI und am besten via sngrep das sip signaling dazu wären dann sehr hilfreich.

Bitte prüfe aber nochmal in den Basisdaten des Amtes, ob hier wirklich bei ausgehendes Script “keines” ausgewählt ist.

Grüße,
Steve


#16

Hallo,
vielleicht hilft folgende Info noch ein wenig…
Dem Benutzer sind also ein internes SNOm Telefon und ein externes Telefon zugiesen, der Ruf sollte also an beiden Telefonen ankommen.
Der Anrufer von extern hört einmal das Klingelzeichen, dann belegt. Am SNOM wird angezeigt “Call completed elsewhere”, das externe Telefon klingelt NICHT. Im Amt ist kein Skript für ausgehende Regeln eingetragen. Direkte Weiterleitung steht auf “JA”.
Stelle ich im Amt Direkte Weiterleitung auf “Nein” dann klinglet das interne SNOM weiter bis einer abhebt, das externe klingelt NICHT.

Mit der letzen Stable (15.11) hat das externe wenigstes geklingelt, allerdings konnte man sich nciht unterhalten. Somit tippe ich mal auf eine Bug,
Könnte das bitte jemand versuch nachzuvollziehen?
Besten Dank!

Gruß
Jens


#17

Hallo Jens,

wenn das externe Telefon als “integrated via mobile Hub” angelegt ist, dann musst du diesen neu konfigurieren. Es kann auch sein das mit dem Update die Amtsholung nicht mehr oder nun doch verwendet werden muss (ich glaub ersteres ist der Fall). Wenn es als nur externes Telefon angelegt ist, wird die Amtsholung schon benötigt.
Wenn mann Empfang vom Handy ausschließen kann, ist es sehr wahrscheinlich, das keine ausgehende Regel greift (hier wird eine mit Quelle * benötigt, das ist auch neu) oder es mit dem Prefix ein Problem gibt.

Grüße,
Steve


#18

Hallo Steve,
zunächst Danke für die Mühe. Das externe Telefon ist nicht via mobile hub angelegt. Ausgehende Regel mit Quelle * existiert. Wäre nett wenn das mal wer nachprüfen könnte ob es ein generelles Problem ist. Schreibe wohl besser den Support direkt an, zahlen ja schliesslich Wartung da soll das auch funktionieren…
Schönen Gruß
Jens