Keine ausgehenden Calls mit "Generisches SIP-Amt" und "toplink Xpress"

Hallo zusammen,

ich hoffe Ihr könnt mir weiterhelfen.
Da leider die Vorlage zu toplink Xpress in der 18 und 19 nicht verwendbar ist,
habe ich das generische SIP-Amt ausprobiert.
Hierbei wurde es zwar möglich eingehende Anrufe entgegennehmen zunehmen, aber beim Versuch Anrufe durchzuführen wird in der CLi ein 500’ter Fehler zurückgegeben.

– Executing [00049151********@mdc_distribute:3] Goto(“SIP/Os1FTjArlWDC4Zt-0000002c”, “mdc_outgoing-15,0049151********,1”) in new stack
– Goto (mdc_outgoing-15,0049151********,1)
– Executing [0049151********@mdc_outgoing-15:1] Gosub(“SIP/Os1FTjArlWDC4Zt-0000002c”, “sub_trunk-outgoing-15,0049151********,1”) in new stack
– Executing [0049151********@sub_trunk-outgoing-15:1] Gosub(“SIP/Os1FTjArlWDC4Zt-0000002c”, “sub_nat2int,s,1(MDC_CALLEE_NUM_INTERNAT,0049151********,00,49,0,2835,0)”) in new stack
– Executing [s@sub_nat2int:1] Verbose(“SIP/Os1FTjArlWDC4Zt-0000002c”, “1,sub_nat2int:: variable: MDC_CALLEE_NUM_INTERNAT - number: 0049151******** - intVAZ: 00 - lkz: 49 - natVAZ: 0 - onKz: 2835 - incoming: 0”) in new stack
sub_nat2int:: variable: MDC_CALLEE_NUM_INTERNAT - number: 0049151******** - intVAZ: 00 - lkz: 49 - natVAZ: 0 - onKz: 2835 - incoming: 0
– Executing [s@sub_nat2int:2] GotoIf(“SIP/Os1FTjArlWDC4Zt-0000002c”, “0?s-emergency,1”) in new stack
– Executing [s@sub_nat2int:3] GotoIf(“SIP/Os1FTjArlWDC4Zt-0000002c”, “0?s-int,1”) in new stack
– Executing [s@sub_nat2int:4] GotoIf(“SIP/Os1FTjArlWDC4Zt-0000002c”, “0?s-int,1”) in new stack
– Executing [s@sub_nat2int:5] GotoIf(“SIP/Os1FTjArlWDC4Zt-0000002c”, “0?s-convert,1”) in new stack
– Executing [s@sub_nat2int:6] GotoIf(“SIP/Os1FTjArlWDC4Zt-0000002c”, “1?s-int,1”) in new stack
– Goto (sub_nat2int,s-int,1)
– Executing [s-int@sub_nat2int:1] Verbose(“SIP/Os1FTjArlWDC4Zt-0000002c”, “1,international”) in new stack
international
– Executing [s-int@sub_nat2int:2] Set(“SIP/Os1FTjArlWDC4Zt-0000002c”, “MDC_CALLEE_NUM_INTERNAT=0049151********”) in new stack
– Executing [s-int@sub_nat2int:3] Return(“SIP/Os1FTjArlWDC4Zt-0000002c”, “”) in new stack
– Executing [0049151********@sub_trunk-outgoing-15:2] Gosub(“SIP/Os1FTjArlWDC4Zt-0000002c”, “sub_int2nat,s,1(MDC_CALLEE_NUM_NAT,0049151********,00,49,0,2835,0)”) in new stack
– Executing [s@sub_int2nat:1] Verbose(“SIP/Os1FTjArlWDC4Zt-0000002c”, “1,sub_int2nat:: variable: MDC_CALLEE_NUM_NAT - exten: 0049151******** - intVAZ: 00 - lkz: 49 - natVAZ: 0 - onKz: 2835 - incoming: 0”) in new stack
sub_int2nat:: variable: MDC_CALLEE_NUM_NAT - exten: 0049151******** - intVAZ: 00 - lkz: 49 - natVAZ: 0 - onKz: 2835 - incoming: 0
– Executing [s@sub_int2nat:2] GotoIf(“SIP/Os1FTjArlWDC4Zt-0000002c”, “0?s-emergency,1”) in new stack
– Executing [s@sub_int2nat:3] GotoIf(“SIP/Os1FTjArlWDC4Zt-0000002c”, “0?nat”) in new stack
– Executing [s@sub_int2nat:4] GotoIf(“SIP/Os1FTjArlWDC4Zt-0000002c”, “1?s-internat,1”) in new stack
– Goto (sub_int2nat,s-internat,1)
– Executing [s-internat@sub_int2nat:1] Set(“SIP/Os1FTjArlWDC4Zt-0000002c”, “MDC_CALLEE_NUM_NAT=0151********”) in new stack
– Executing [s-internat@sub_int2nat:2] Return(“SIP/Os1FTjArlWDC4Zt-0000002c”, “”) in new stack
– Executing [0049151********@sub_trunk-outgoing-15:3] SIPAddHeader(“SIP/Os1FTjArlWDC4Zt-0000002c”, “P-Preferred-Identity: sip:02835*******@sip.toplink-xpress.de”) in new stack
– Executing [0049151********@sub_trunk-outgoing-15:4] SIPAddHeader(“SIP/Os1FTjArlWDC4Zt-0000002c”, “P-Asserted-Identity: sip:02835*******@sip.toplink-xpress.de”) in new stack
– Executing [0049151********@sub_trunk-outgoing-15:5] Set(“SIP/Os1FTjArlWDC4Zt-0000002c”, “CALLERID(num)=02835*******”) in new stack
– Executing [0049151********@sub_trunk-outgoing-15:6] GotoIf(“SIP/Os1FTjArlWDC4Zt-0000002c”, “0?searchdone”) in new stack
– Executing [0049151********@sub_trunk-outgoing-15:7] UserEvent(“SIP/Os1FTjArlWDC4Zt-0000002c”, “ResolveCallerName,Strategy: system,Outbound: 1”) in new stack
– Executing [0049151********@sub_trunk-outgoing-15:8] Wait(“SIP/Os1FTjArlWDC4Zt-0000002c”, “0.25”) in new stack
– Executing [0049151********@sub_trunk-outgoing-15:9] Verbose(“SIP/Os1FTjArlWDC4Zt-0000002c”, “1,MDC_RESOLVENAME_HITS = 0”) in new stack
MDC_RESOLVENAME_HITS = 0
– Executing [0049151********@sub_trunk-outgoing-15:10] Verbose(“SIP/Os1FTjArlWDC4Zt-0000002c”, "1,MDC_DIALCALLEENAME = ") in new stack
MDC_DIALCALLEENAME =
– Executing [0049151********@sub_trunk-outgoing-15:11] Verbose(“SIP/Os1FTjArlWDC4Zt-0000002c”, “1,end call deflection”) in new stack
end call deflection
– Executing [0049151********@sub_trunk-outgoing-15:12] Verbose(“SIP/Os1FTjArlWDC4Zt-0000002c”, “1,Top Link SIP - Standardtelefonie”) in new stack
Top Link SIP - Standardtelefonie
– Executing [0049151********@sub_trunk-outgoing-15:13] Set(“SIP/Os1FTjArlWDC4Zt-0000002c”, “__SPYGROUP=0151********:102”) in new stack
– Executing [0049151********@sub_trunk-outgoing-15:14] ExecIf(“SIP/Os1FTjArlWDC4Zt-0000002c”, “0?Set(CHANNEL(hangup_handler_push)=hdlr-hint,s,1())”) in new stack
– Executing [0049151********@sub_trunk-outgoing-15:15] ExecIf(“SIP/Os1FTjArlWDC4Zt-0000002c”, “0?Set(DEVICE_STATE(Custom:)=INUSE)”) in new stack
– Executing [0049151********@sub_trunk-outgoing-15:16] Dial(“SIP/Os1FTjArlWDC4Zt-0000002c”, “SIP/mdc_trunk_conf-14/0151********,t”) in new stack
== Using SIP RTP TOS bits 184
== Using SIP RTP CoS mark 5
– Called SIP/mdc_trunk_conf-14/0151********
– Got SIP response 500 “Server Internal Error” back from 213.218.12.195:5060
– SIP/mdc_trunk_conf-14-0000002d is circuit-busy
== Everyone is busy/congested at this time (1:0/1/0)
– Executing [0049151********@sub_trunk-outgoing-15:17] Return(“SIP/Os1FTjArlWDC4Zt-0000002c”, “”) in new stack
– Executing [0049151********@mdc_outgoing-15:2] Hangup(“SIP/Os1FTjArlWDC4Zt-0000002c”, “38”) in new stack
== Spawn extension (mdc_outgoing-15, 0049151********, 2) exited non-zero on ‘SIP/Os1FTjArlWDC4Zt-0000002c’
– Executing [h@mdc_outgoing-15:1] Gosub(“SIP/Os1FTjArlWDC4Zt-0000002c”, “def_hangup,s,1(,CONGESTION,CALL)”) in new stack
– Executing [s@def_hangup:1] NoOp(“SIP/Os1FTjArlWDC4Zt-0000002c”, “>>>def_hangup:: EXTEN: DIALSTATUS: CONGESTION QUEUESTATUS: REASON: CALL”) in new stack

Neben den hier von toplink Xpress vorgegeben Einstellungen ist bei der ausgehenden Regel die CIDNumer mit der zu übermittelnden Nummer versehen worden.

Hallo zusammen,
ich habe das gleiche Problem, dass ich keine ausgehenden Telefonate mit toplink-xpress hinbekomme. Gibt es hier schon funktionierende Lösungen?

Wir haben als Amt den SIP-Trunk Anbieter “Toplink xpress” ausgewählt.
Wir haben 3 aufsteigende Telefonnummern.

Eingehende Telefonate funktionieren.
Leider funktionieren keine ausgehenden Telefonate.

Im Feld Option habe ich u.a. dies eingetragen (gehabt):

fromuser=‘Usernamen’
username=‘Usernamen’
fromdomain=sip.toplink-xpress.d e
secret=‘Passwort’
type=peer
qualify=yes
insecure=port,invite
endpoint/disallow=all
endpoint/allow=alaw
endpoint/from_domain=sip.toplink-xpress.d e
transport=UDP

Die Community Vorlage für Toplink xpress funktioniert nicht mehr. Gibt es hier schon Updates?

Toplink selber gibt im März 2019 folgende Hilfestellung unter: https://www.toplink-xpress.de/wie-kann-ich-meinen-ip-anschluss-an-einer-asterisk-basierten-anlage-einrichten/

Auf der Seite [rogermayer .info] habe ich folgendes entdeckt: https://rogermayer.info/asterisk-konfiguration-fur-toplink-xpress-sip-trunk/

Bisher jedoch alles ohne Erfolg.

Kann mir hier im Forum jemand weiterhelfen, so dass ich mit toplink aus raus telefonieren kann?

Vielen Dank schon einmal dafür!

Hi,

versucht es mal mit der Option
endpoint/from_user=
(also wirklich nichts dahinter setzten), ansonsten wird die From-Nummer nicht aus der Regel gesetzt sondern der Username hier eingesetzt. Wenn auch das nicht hilft bräuchte ich unverbindlich von einem von euch einen SIP Tracie funktionierend (17) und scheiternd (19), dann kann ich ggf hilfreiche Optionen raussuchen.

Grüße,
Steve

Hi,

ich habe deinen Rat befolgt. Das Feld Option sieht nun so aus:
fromuser=‘Benutzername’
fromdomain=sip.toplink-xpress.de
username=‘Benutzername’
secret=‘Passwort’
type=peer
qualify=yes
insecure=port,invite
endpoint/from_user=

Leider ist es auch so noch nicht möglich ausgehende Telefonate zu führen.
Der Account wird registriert, bei “peer” steht allerdings “not in use”.

Wie kann ich einen SIP Tracie funktionierend (17) und scheiternd (19) durchführen und loggen?
Funktionierend kann hier allerdings nur eingehend sein.

Ich hoffe, wir kriegen es hin!
Besten Dank soweit!

bitte
fromuser=‘Benutzername’
fromdomain=sip.toplink-xpress.de
username=‘Benutzername’
secret=‘Passwort’
type=peer
qualify=yes
insecure=port,invite
weglassen, das ist alles chan_sip syntax und wird über die anderen Spalten in korrekter Syntax gesetzt.

Vielen Dank für den Tipp.
Jetzt steht unter Option nur noch dies: endpoint/from_user=

Leider klappt es noch immer nicht.

Soll ich zwei Log Mitschnitte posten, einen funktionierenden reinkommenden Anruf und einen versuchten ausgehenden Anruf?

Hallo Steven,
vielen Dank schon mal das Du Dich dem Thema angenommen hast.

Bevor wir weiter im Trüben rumstochern kannst Du doch sicher sagen welche Felder in der Version 19 ausgefüllt werden müssen, damit wir die Vorgabe von toplink-xpress überhaupt erfüllen was die chain_sip Syntax angeht.

Dann erst ist davon auszugehen, dass wir alle einen definierten Ausgangspunkt haben.
Danke im Voraus.

Guten Morgen,
ich habe vom toplink Support eine Antwort bekommen, die einen eingehenden und einen ausgehenden Anruf überprüft haben.

Die schreiben folgendes:

Sehr geehrter Kunde,

das Problem hier sind die abweichenden Informationen bei Register und
Anrufinvite im From und Contactfeld.
Haben Sie die Möglichkeit dies so einzustellen damit hier die gleichen Infos
verschickt werden?

From: sip:P1022641971@sip.toplink-xpress.de
From: sip:P1022641971@81.27.163.99:5060

Contact: sip:+492319896996@81.27.163.99:5060
Contact: sip:P1022641971@81.27.163.99:5060

2020/08/17 09:54:10.056349 81.27.163.99:5060 -> 213.218.12.195:5060
REGISTER sip:sip.toplink-xpress.de:5060 SIP/2.0
Via: SIP/2.0/UDP
81.27.163.99:5060;rport;branch=z9hG4bKPje3322da2-97f2-45fa-bc26-3f1aa01c34a9
From:
sip:P1022641971@sip.toplink-xpress.de;tag=740a0419-8f56-43e0-bc94-843d47188b05
To: sip:P1022641971@sip.toplink-xpress.de
Call-ID: cc105952-e161-4355-9fb4-88a79079cb79
CSeq: 62979 REGISTER
Contact: sip:+492319896996@81.27.163.99:5060
Expires: 490
Allow: OPTIONS, REGISTER, SUBSCRIBE, NOTIFY, PUBLISH, INVITE, ACK, BYE, CANCEL,
UPDATE, PRACK, MESSAGE, REFER
Max-Forwards: 70
User-Agent: Asterisk PBX 16.8.0
Authorization: Digest username=“P1022641971”, realm=“sip.toplink-xpress.de”,
nonce=“Xzo4zl86N6K9OhPWPU0F4hVMuD0inBN1”, uri=“sip:sip.toplink-xpress.de:5060”,
response=“795c00c5a0e68d77770
9c247f51fc0”, cnonce=“ed855cd3050d42ae886edf638ba84c4d”, qop=auth, nc=00000001
Content-Length: 0

2020/08/17 09:50:44.486647 81.27.163.99:5060 -> 213.218.12.195:5060
INVITE sip:0177864819@sip.toplink-xpress.de:5060 SIP/2.0
Via: SIP/2.0/UDP
81.27.163.99:5060;rport;branch=z9hG4bKPj83fa86b3-dd35-405b-86b3-72e8ee8f3e0d
From:
sip:P1022641971@81.27.163.99:5060;tag=0cfd9811-b641-44f3-ad21-4ae1e049b6ea
To: sip:0177864819@sip.toplink-xpress.de
Contact: sip:P1022641971@81.27.163.99:5060
Call-ID: 503dd5eb-53d5-4fd4-8f3f-ceff4030652d
CSeq: 16744 INVITE
Allow: OPTIONS, REGISTER, SUBSCRIBE, NOTIFY, PUBLISH, INVITE, ACK, BYE, CANCEL,
UPDATE, MESSAGE, REFER
Supported: timer, replaces, norefersub
Session-Expires: 1800
Min-SE: 90
P-Preferred-Identity: sip:+492319896996@sip.toplink-xpress.de
P-Asserted-Identity: sip:+492319896996@sip.toplink-xpress.de
Max-Forwards: 70
User-Agent: Asterisk PBX 16.8.0
Content-Type: application/sdp
Content-Length: 235

Mit freundlichen Grüßen aus Darmstadt

Ihr toplink-Team

das Problem hier sind die abweichenden Informationen bei Register und
Anrufinvite im From und Contactfeld.
Haben Sie die Möglichkeit dies so einzustellen damit hier die gleichen Infos
verschickt werden? <<

Diese Frage vom Toplink- Support-Team möchte ich hier an die Experten weiterleiten. Gibt es die Möglichkeit und welche Einstellung muss ich hier verwenden?

Besten Dank für Eure Hilfe.

Moin moin,
gibt es von Seiten des pascom Support ein Hinweis, wie die Support Informationen vom toplink Support angewendet werden können?

Ansonsten habe ich etwas auf Grundlage der Tipps vom TOPLINK Support experimentiert.
Mit folgenden Einstellungen funktionieren nun eingehende als auch ausgehende Telefonate!

Für TOPLINK xpress bitte folgende Account-Einstellungen nehmen:

Defaultnummer > (Benutzername)
Benutzername > (Benutzername)
Passwort > (Passwort)
Domain > (leer)
Anmeldename > (leer)
Host > sip.toplink-xpress.de
Optionen > endpoint/from_domain=sip.toplink-xpress.de
Register > ja
Port > 5060
Nummerregistrieren > ja
Rufnummer-Ermittlung > Request-URI
Rufnummern-Übermittlung > Auto
Rufnummern-Unterdrückung > From

Hallo ToGa,

ausgehende Gespräche funktionieren jetzt, aber leider bekomme ich bei den eingehenden Gesprächen die Ansage das die Nummer nicht richtig sei. :worried:

Folgende Konfiguration habe ich vorgenommen:
(Evtl. habe ich etwas bei eingehend/ausgehen Rufen anders Konfiguriert was zu dem Verhalten führt.)

Basisdaten:
Präfix eing. Nummer = (leer)
internationale Vorwahl = 00
Landeskennzahl = 49
nationale Vorwahl = 0
Ortskennzahl = (unsere Vorwahl)
Telefonbuchabfrage = Ja
Fallback Durchwahl = - kein Fallback -
Skript ausgehende Regeln = - keines -
Direkte Weiterleitung * = Nein
Freizeichen-Erzeugung * = Sende SIP-Ringing und -Progress

Accounts:
Defaultnummer = (Benutzername)
Benutzername = (Benutzername)
Passwort = (Passwort)
Domain = (leer)
Anmeldename = (leer)
Host = sip.toplink-xpress.de
Optionen = endpoint/from_domain=sip.toplink-xpress.de
Register = ja
Port = 5060
Nummerregistrieren = ja
Rufnummer-Ermittlung = Request-URI
Rufnummern-Übermittlung = Auto
Rufnummern-Unterdrückung = From

Eingehende Rufe:
Quelle = *
Ziel = (Unsere komplette Nummer mit +49 )
Durchwahl = (Nummer eines Benutzers)
CIDName = (leer)
CIDNummer = (leer)
Sprache = Deutsch

Ausgehende Rufe:
Im Client zeigen = Nein
In-Prefix = 0
Quelle = *
Ziel = *
CIDNummer = (Unsere komplette Nummer mit 0 statt +49 )
Out-Prefix = (leer)
Out-Suffix = (leer)
Verbieten = nein
PIN = (leer)
Übertragunskapazität = Sprache
Account = (Der einzige vorhandene Account)

Ich würde bei “Eingehende Rufe” - “Ziel” spontan die +49 mit der 0 ersetzen.
Bzw. zum Testen ein * bei Ziel eingeben.

Jetzt funktioniert es!

Die Fallback Durchwahl musste besetzt sein.

Ich werden den Thread damit auf gelöst setzten.

@christiande
Mit der Fallback Durchwahl hast du das Problem jedoch nicht gelöst.
Du hast lediglich dem System gesagt: “Wenn ein Anruf reinkommt, welcher nicht zuzuordnen ist, soll an Durchwahl XX vermittelt werden.”
Ich denke, dass der Fehler im Feld “Ziel” unter “Eingehende Rufe” zu suchen ist.

Poste bitte den Auszug aus der CLI, während du deine toplink Nummer anrufst.

Hallo Christiande,

ich habe die ganz Zeit eine Fallback-Nummer eingetragen gehabt, daher habe ich das Problem mit den eingehenden Nummern nicht bemerkt. Allerdings kannst Du hier auch Teams (Nummern) angeben, so dass hier mehrere Teilnehmer zeitgleich angerufen werden.

Ansonsten habe ich die Lösung auch nun für eingehende Nummern:
Ändere bitte bei
AMT - Account
den Eintrag unter “RufnummerErmittlung” auf “To-Header”.

Im Anschluss kannst Du bei eingehende Anrufe Regeln erstellen:
Quelle: *
Ziel: +49…1 (Deine Toplink-Nummer)
Durchwahl: (existierende Pascom Durchwahl)

Quelle: *
Ziel: +49…2 (Deine Toplink-Nummer)
Durchwahl: (existierende Pascom Durchwahl)

etc.

Viel Erfolg!

Hallo ToGa,

perfekt, jetzt klappt es auch mit den einzelnen Nummern!
Vielen Dank für Deinen Einsatz!!!

Gruß
Christian