Klingeltöne findet der Kunde schrecklich

kann ich in der Pascom klingeltöne hinterlegen und diese dem endgerät zufügen bei Yealink und Snom785?

habe gemerkt das ich die klingeltöne überhaupt nicht ändern kann, da diese wohl nach der provisionierung auf klingelton1 gefixed sind.
Wo kann ich dieses ändern damit ich auf der webgui vom snom einen individuellen klingelton einstellen kann?

Hallo @Michael-Roehmann,

wir setzten für interne und externe Klingeltöne unterschiedliche Alert Header die die Telefone auswerten können um externe von internen Anrufern zu unterscheiden. Diese übersteuern meist die reguläre für den Account ausgewählten Klingeltöne. Bei Snom im WebUI kannst du den Klingelton unter Präferenzen ändern. Dort kannst du für alert-internal und alert-external den Klingelton jeweils auf einen anderen per Dropdown setzen.

Das ganze geht auch per angepaster Basiskonfig vom Server provisioniert:

Yealink:
distinctive_ring_tones.alert_info.1.text = alert-external
distinctive_ring_tones.alert_info.1.ringer = Ring1.wav
distinctive_ring_tones.alert_info.2.text = alert-internal
distinctive_ring_tones.alert_info.2.ringer = Ring2.wav

Snom:
alert_internal_ring_text!: alert-internal
alert_external_ring_text!: alert-external
alert_internal_ring_sound!: Ringer1
alert_external_ring_sound!: Ringer1

Valid Values Snom:
Ringer1, Ringer2, Ringer3, Ringer4, Ringer5, Ringer6, Ringer7, Ringer8, Ringer9, Ringer10, silent

Grüße,
Steve

@Steve Kann man denn die Ringer1, Ringer2 etc bei Snom austauschen ? Denn man kann ja den individual hier im alert-external nicht auswählen obwohl man ihn unter audio konfigurieren kann.

:wink:

Hallo @Daniel115,

du meinst vermutlich denjenigen den man per URL angeben kann? custom_melody_url
Laut Snom Doku und Webdropdown ist der hier leider nicht auswählbar, du kannst aber
alert_internal_ring_text!:
alert_external_ring_text!:

Setzen, dann greift immer der am Account konfigurierte (und dort vermutlich auch individuell auswählbare) Klingelton.
Individueller Alert Header und individueller Klingelton scheint wohl Snom zu viel der Individualität zu sein :wink:

Grüße,
Steve

Wo genau muss ich das denn setzen, siehe Screenshot?

In der Sektion “Klingeln per Alert-Info” den Inhalt von “Nachricht interner Ruf” und “Nachricht externer Ruf” rauslöschen (vorsicht wird von uns so provisioniert, sollte also auch in der Basisconfig abgeändert werden). Dadurch wird der hier ausgewählte Klingelton nicht forciert (die alert-info Header werden also nicht mehr berücksichtigt).
Dann unter Identität 1 (wieder ganz link im Menü zu finden) den Individuellen Ton einstellen und drunter die URL angeben. Ich habe das nicht getestet, sollte aber so funktionieren.

öhm sorry aber finde in der Basicconfig keine alert bzw Header infos:

{{!-- password protection --}}
admin_mode!: off
admin_mode_password&: {{{admin_password}}}
admin_mode_password_confirm&: {{{admin_password}}}
http_pass&: {{{071ipp_authpass}}}
http_user&: {{{071ipp_authuser}}}
http_scheme&: off
{{!-- date/time --}}
ntp_server&: pool.ntp.org
date_us_format&: {{{list_key lang “de_DE” “off” “en_US” “on”}}}
time_24_format&: on
timezone&: {{{list_key lang “de_DE” “GER+1” “en_US” “GBR-0”}}}
{{!-- tone set --}}
tone_scheme&: {{{list_key lang “de_DE” “GER” “en_US” “GBR”}}}
{{!-- behaviour --}}
mailbox_active!: on
peer_to_peer_cc&: off
{{#fw_less 071ipp_cur_fw “8.7.4”}}
prioritise_pbx_number_lookup!: off
{{else}}
contact_source_priority = Sip Tbook Ldap Memory
{{/fw_less}}
guess_number&: off
logon_wizard&: off
answer_after_policy&: idle
auto_connect_indication&: on
{{#fw_less 071ipp_cur_fw “8.7.2”}}
auto_connect_type&: auto_connect_type_handsfree
callpickup_dialoginfo&: off
{{else}}
intercom_connect_type&: intercom_connect_type_handsfree
goto_monitor_state_on_line_activity:& off
{{/fw_less}}
call_completion&: off
call_join_xfer&: on
{{#fw_less 071ipp_cur_fw “8.7.5”}}
call_waiting&: {{{bool 011acc_callwaiting}}}
conf_hangup&: on
{{else}}
call_waiting1&: {{{bool 011acc_callwaiting}}}
conf_hangup1&: on
{{/fw_less}}
challenge_response&: off
display_method&: display_name_number
ignore_security_warning&: on
intercom_connect_type&: intercom_connect_type_handsfree
transfer_on_hangup&: on
transfer_on_hangup_non_pots&: on
transfer_on_hangup_with_starcode&: on
contact_source_priority!: InternalTbook Ldap Sip Memory
prioritise_asserted!: off
recording_mechanism!: NONE
{{!-- SIP general --}}
retry_after_failed_register&: 3,6:120
user_phone&: off
{{!-- SIP account --}}
user_active1&: on
user_auth_tag1&: off
user_name1&: {{{013pee_username}}}
user_pass1&: {{{013pee_password}}}
user_realname1&: {{{012loc_bez}}}
user_sipusername_as_line1&: on
user_mailbox1!: {{{setting sys.asterisk.dialplan.global.voicebox.watched.value }}}
user_idle_text1&: {{{displayname}}}
user_srtp1&: {{#if_eq voip_media ‘srtp’}}on{{else}}off{{/if_eq}}
user_savp1&: mandatory
user_host1&: {{{cs_domain}}}
{{#if_eq voip_sip ‘tls’}}
user_outbound1&: {{{httpip}}}:5061;transport=tls
{{else}}
{{#if_eq voip_sip ‘udp’}}
user_outbound1&: {{{httpip}}}
{{else}}
user_outbound1&: {{{httpip}}}:5060;transport=tcp
{{/if_eq}}
{{/if_eq}}
{{!-- SIP push --}}
offer_gruu&: off
filter_registrar&: off
network_id_port&: {{#if_eq voip_sip ‘tls’}}5061{{else}}5060{{/if_eq}}
{{!-- language --}}
language&: {{{list_key lang “de_DE” “Deutsch” “en_US” “English”}}}
web_language&: {{{list_key lang “de_DE” “Deutsch” “en_US” “English”}}}
country_code&: {{{list_key lang “de_DE” “0049” “en_US” “0044”}}}
{{!-- keys --}}
fkey0!: url http://{{{httpip}}}/provisioning/{{{071ipp_mac}}}/pui/menu?callid=$call-id
fkey_label0!: pascom
dkey_record!: url http://{{{httpip}}}/provisioning/{{{071ipp_mac}}}/pui/monitor/record?callid=$call-id
{{!-- ldap --}}
gui_fkey1!: keyevent F_DIRECTORY_SEARCH
dkey_directory!: url http://{{{httpip}}}/provisioning/{{{071ipp_mac}}}/pui/phonebook/search?callid=$call-id
{{#if_eq ldap_proxy ‘off’}}
ldap_base!:
ldap_display_name&:
{{#fw_less 071ipp_cur_fw “8.7.3”}}
ldap_lookup_ringing&:
{{/fw_less}}
ldap_name_attributes&:
ldap_number_attributes&:
ldap_number_filter!:
ldap_password&:
ldap_port&:
ldap_over_tls&: off
ldap_search_filter&:
ldap_server&:
ldap_username&:
{{else}}
ldap_base!: dc=phonebook,{{{ldap_suffix}}}
ldap_display_name&: %cn
{{#fw_less 071ipp_cur_fw “8.7.3”}}
ldap_lookup_ringing&: on
{{/fw_less}}
ldap_name_attributes&: cn sn displayName
ldap_number_attributes&: telephoneNumber mobile
ldap_number_filter!: (&(telephoneNumber=%)(cn=*))
ldap_password&: {{{ldap_password}}}
{{#if vpnconnection}}
ldap_port&: 389
ldap_over_tls&: off
{{else}}
ldap_port&: 636
ldap_over_tls&: on
{{/if}}
ldap_search_filter&: (|(cn=%)(sn=%))
ldap_server&: {{{httpip}}}
ldap_username&: cn={{{ldap_username}}},dc=devices,{{{ldap_suffix}}}
{{/if_eq}}
{{! --logging --}}
syslog_server&:
log_level&:
{{!-- provisioning --}}
subscribe_config&: on
pnp_config&: off
update_policy&: settings_only
provisioning_order&: dhcp:stop pnp:stop tr69:stop redirection:stop

ldap_lookup_ringing&: off <-- funktioniert auch nicht

ldap_lookup_ringing&:
{{/fw_less}} <-- ???

dann trag es doch einfach ein …

könntest du netter weise auch schrieben was ich genau wo eintragen muss
damit ich unter den einzelnen Identitäten auch änderungen vornehmen kann oder er die einstellungen in der Präferenz annimmt ?

Hi,

vorneweg alles was nicht provisioniert wird kann jederzeit von den Benutzern am Telefon angepasst werden. Das {{/fw_less}} schließt das if/else Konstrukt ab, da bestimmte Settings Firmwareversionsabhängig sind.
Da wir alert-internal/external nicht provisionieren (sorry das hatte ich nicht auf dem Schirm) ist es wohl der Snom Default Wert. Wenn du das über die Provisionierung überschreiben willst dann wie oben beschrieben folgende zwei Zeilen in der Basiskonfig einfach mit aufnehmen (z.B. am Ende, es ist egal wo solange diese nicht in einem if/else Block liegen):

Der Übersicht halber kannst du auch eine Überschrift in Form von einem Kommentar darüber setzen:
{{!-- custom settings --}}

Über den ? Button oder wenn du die Einstellungsseite vorher/nacher vergleichst kannst du ermitteln wie die einzelnen Settings heißen, Wenn du also den CustomKlingelton für alle über die Provisionierung setzten willst:
user_ringer1!: Custom
user_custom1!: http://…

Grüße,
Steve

1 Like

Das Problem ist, dass wenn ich das lösche und der Alert Info nicht mehr aktiv ist, lässt sich in der Identität 1 der Klingelton nicht ändern, und auch kein Individueller Klingelton oder etwas anderes auswählen. er springt dann immer wieder auf Klingel 1 … hat das irgendjemand hin bekommen?

Frage: Ist das normal, dass das so derart schwierig ist einen Klingelton zu ändern? Also ich hätte nie gedacht, dass man das mit in ein Anforderungsprofil aktueller Projekte aufnehmen muss? egal ob Pascom oder SNOM aber im heutigen Zeitalter hätte ich das nicht für möglich gehalten.

Wir hatten hier ähnliche Probleme, bei externen Anrufen wurde immer Klingelton 1 gewählt, obwohl am DECT Gerät ein anderen Klingelton gewählt war.
Lösen konnten wir es dadurch, dass wir auf der Pascom unter Appliance → Systemeinstellungen nach (Alert-Info) für externe Gespraeche suchen und den Wert auf
<http://www.notused.de>;;x-line-id=0 ändern. Ab dem Zeitpunkt wurde der am Endgerät gewählte Klingelton auch tatsächlich abgespielt.

Moin @office-ops nur noch einmal zur Sicherheit, du hast aus dem

http://www.notused.de;info=alert-external;x-line-id=0

folgendes gemacht? hast du das \vor dem ersten ; gelöscht?

http://www.notused.de;;x-line-id=0

Grüße

Daniel