Mail2Fax funktioniert nicht

german

#1

Hallo liebe Community,
ich würde mich doch gerne nochmal an euch erfahrene User wenden.
Ich versuche aktuell Mail2Fax bei einem Kunden einzurichten. Einen Exchange SMTP Relay habe ich mit einem Smarthost eingerichtet. Wenn jetzt aber eine Mail an Community@faxnr.fax gemailt wird passiert leider genau gar nichts.
Wie debugge ich das am besten? Gibt es eine Möglichkeit zu überprüfen, wie weit diese Mail in der Verarbeitetung kommt? Eventuell Mailserver oder Hylafax Logs in denen sowas getrackt wird?
Leider kann ich auch nicht zu 100% sagen ob die Weiterleitung von Exchange überhaupt funktioniert.

Schonmal danke für eure Zeit.

Liebe Grüße,
Warmitrax


#2

Wir sind noch auf Pascom 17.10, da scheint es ja Probleme mit Pascom 18 zu geben, die können wir aber schonmal ausschließen.


#3

Hallo @Warmitrax,

zunächst per SSH auf der Anlage einloggen. Nun gibt es ein paar Möglichkeiten.

Eine Überwachung des Emailverkehr kann man mit folgendem Befehl aktivieren.
tail -f /var/log/exim4/mainlog

Zusätzlich kann man den mainlog durchstöbern, um z.B vergangene Probleme zu identifizieren.

Pro eingerichtetem Faxkanal erzeugt die pascom Anlage ein virtuelles IAX Modem. Mit dem Befehl faxstate können Sie herausfinden ob diese laufen oder Probleme verursachen.

Den eigentlichen Faxversand über die Anlage sehen Sie in der Asterisk CLI. Hier lassen sich dann alle Schritte des IAX Modem verfolgen und debuggen.

Grüße
Andi


#4

Okay, das Mainlog gibt uns die Meldung “Relay not permitted” das wird wohl vom Exchange kommen denke ich mal?


#5

Ja hängt mit der Konfig Ihres Exchange zusammen. Der verbietet das Senden mit der unter “Appliance -Dienste - Basisdaten” eingestellten Absenderadresse über Ihren Emailserver.

Grüße
Andi


#6

Okay das habe ich behoben. Wir sind glatt einen Schritt weiter.
Danke dir @Steve
Jetzt kriege ich
Betreff: Fehler beim Faxversand

Email hat keinen text/plain Teil.

Per Mail wenn man es testet. Ich wollte mir die Konfiguration des Mailservers anschauen, wie in der Doku beschrieben hier. Ich habe allerdings keine Ordner der Mimetype heißt…Ist da bei mir was kaputt oder ist die Doku hier nicht aktuell?


#7

glaube nicht das bei dir etwas kaputt ist. Der Hylafaxdienst vermisst beim prüfen deiner Mail die du faxen möchtest den Plain Text. Hier wirst du versuchen, nur einen Anhang zu versenden. In den Fax Einstellungen auf der Anlage einfach “Nur Anhang versenden” einstellen dann sollte es klappen.
Der mimetype Ordner wird wahrscheinlich erst bei einer erfolgreichen Konvertierung erscheinen.


#8

Wenn ich es auf “Anhang versenden” umstelle bekommen wir die Meldung: „Keine Dokumente zu senden“


#9

Leider hat der Tipp von @Andi nicht geholfen. Ich habe aber alle für mich erstichtlich beteiligten Logs ausgelesen. Und ergänze die hier mal:
syslog:
macht gar nichts
exim4/mainlog:
2018-11-05 16:44:07 1gJh2t-0004wr-3y 2018-11-05 16:44:07 1gJh2s-0004wW-FV => Firedrich@faxnr.fax R=fax T=fax
2018-11-05 16:44:07 1gJh2s-0004wW-FV Completed
2018-11-05 16:44:07 1gJh2t-0004wr-3y => NAME@FIRMA.com R=smarthost T=remote_smtp_smarthost H=IP Echange[IP Exchange] X=TLS1.2:RSA_AES_256_CBC_SHA256:256 DN=“CN=EXCHANGE”
2018-11-05 16:44:07 1gJh2t-0004wr-3y Completed
Im CLI taucht leider nichts auf
Der Relay im Exchange verschickt die mail mit der Domain .fax an den Pascom Server weiter.
Im Anschluss bekommt der jenige der versucht hat das Fax zu versenden. Je nach KOnfiuration zwei verschiedene Meldungen:
Wenn in der Pascom “nur Anhang versenden” aktiviert ist, bekommt man die Rückmeldung vom PAscom SMTP-User: “Keine Dokumente zu senden”
Wenn man “Inhalt der Email mitfaxen” eingibt, dann erhält man Email enthält keinen text/plain Teil

Ich habe mich an diesem Problem schon komplett abgebrochen und bin um jede FOrm der unterstützung dankbar.

Liebe Grüße,
Warmitrax