MobileApp, Anrufer hört mich extrem schlech/abgehackt

Hallo zusammen,

bei der MobileApp habe ich das Problem dass ich den Anrufer halbwegs tragbar verstehe aber er mich so gut wie gar nicht. Obwohl ich hier im WLAN bin, also im gleichen Netz wie die MD.

Kann ich das Problem irgendwie eingrenzen bzw. wo kann ich ansetzen?

Viele Grüße
Sven

Hallo @pixel24,

du kannst dir die Qualitätsdaten im Grafana zu jedem Call anschauen, dort werden entsprechende Metriken ausgewertet. Die Daten könnten helfen um eine “schlechte” Verbindung einzugrenzen (Telefon -> Server oder Server -> Mobile Client).

Das Template nennt sich Call Quality Overview für aktuell laufende Gespräche. Historische Gespräche kannst du aus dem Template Overview unter Details (in der Gesprächsliste unten) aufrufen.

In der Doku sind diese Features noch nicht enthalten da noch Beta.

Gruß,
Rapha

1 Like

Hi Sven,

für eine reibungslose Telefonie im WLAN sind einige Funktionen der APs (Fast Roaming und 802.11e (QoS) um die wichtigsten zu nennen) notwendig, auch Frequenzwechsel oder Auslastung durch andere APs/Nachbarn kann zu Jitter und Packetloss führen.

Wenn Verbindungen von Extern eingerichtet/erlaubt sind könnte man mal via MobileDaten+LTE Testen dann weiß man des es definitiv am WLAN liegt. Ohne das mobile Softphone zu verwenden könnte man auch mal den GSM Schalter verwenden.

Grüße,
Steve

Hallo @pixel24,

ebenfalls hilfreich ist, als ersten Versuch mal mit der App die Voicemailbox anzurufen und zu prüfen, ob diese gut verständlich ist.

Wenn das klappt, *80 wählen und einen Text aufsprechen und Anhören.

Falls Zugriff von extern eingerichtet ist, kann man das ganze dann auch via LTE versuchen.

Grüße,
Jan

Ok, fange mal mit dem einfachsten an. WLAN am Handy aus, Handy ist im 4G mit vollem Signal.

  • externer Anrufer hört mich jetzt besser aber noch immer abgehackt
  • In der MobileApp auf das Bandsymbol (denke das ist die Voicemailbox). Klare Stimme
  • Mit *80 was aufgesprochen: Klar und deutlich

War gerade zum ersten mal in der Auswertungs-Oberfläche. Habe mich versucht zurecht zu finden was nicht ganz einfach ist. Per Default werden da ja “nur” System-Auslastung angezeigt. Wie komme ich an ein Template bzw. binde es ein?

Dann bist du auf dem falschen Grafana.
Es gibt einmal das für die Appliance (Server) unter Port 8443 [vmtl. warst du hier] und das Grafana der Instanz über Information -> Analytics (siehe auch https://www.pascom.net/doc/de/modules/statistics/).

Grafana der Appliance: https://pascom-ip:8443/api/analysis/
Grafana der Instanz: https://pascom-ip/instanz/analysis/
Bei Aufruf über Information -> Analytics wird der admin automatisch angemeldet.

Gruß,
Rapha

so, habe mal mal getestet und mich vom Festnetz anrufen lassen und das Gespräch am Handy (MobileApp ohne WLAN) entgegen genommen. Der Anrufer nimmt einen deutlichen Hall wahr. In der Auswertung stellt es sich so dar:

Kann man daraus irgendwelche Schlüsse ziehen?

Ist ein Cisco WAP121. Habe die aktuelle Firmware aufgespielt. Fast Roaming und 802.11e scheint er nicht zu können. Was brauche ich da für ein Gerät bzw. welche sind dafür gut geeignet?

Der zweite Stream (0xb8977a00) hat einen hohen Jitter-Wert, dies ist die Festnetzverbindung vom pascom in Richtung Provider (0049722…), also die Verzögerung der RTP-Pakete (Sprache) zum Provider, heißt ausgehend und somit klingt es bei deinem Gesprächspartner abgehackt. Die Gegenrichtung sieht aber gut aus (0x2e6bf332), also dein Gesprächspartner zu dir.

Die Mobile-Client-Verbindung (0x12e8a9cb und 0x00bc3a05) hat offensichtlich keinen großen Einfluss auf die Verbindungsqualität.

Du könntest nochmal ein etwas längeres Gespräch (1-2 Minuten) führen um mehr Daten zu bekommen, hier waren es nur ~10 Sekunden.

Wenn ich die Daten so korrekt interpretiere sieht es zunächst so aus also ob deine Internetverbindung (bzw. die Verbindung zum Telefonie-Provider) die Sprachpakete nicht priorisiert oder du hast eine zu geringe Bandbreite (im Upload).

Gruß,
Rapha

ok, werde ich nachher testen

Down habe ich 60MBit und Up 30MBit

Der Anbieter ist ja ein Lokaler. Was genau muss ich dort nachfragen? Ob Sprachpakete priorisiert werden?

Falls du von deinem Anbeiter Internet + Telefonie beziehst kann nachfragen nicht schaden, im anderen Fall, also getrennte Anbieter, wird dir keiner von beiden eine Priorisierung garantieren.

Hatte mal bei einem Kunden eine 10MBit/s im Upload, bei starker Belastung der Leitung wurden die Gespräche auch sehr unangenehm (abgehackt).

Ja, sind getrennt. Glasfaser von den Stadtwerken, SIP-Trunk von Peoplefone

So, habe mal alle Gerät (Server, Firewall, MD, Telefone …) neu gestartet und mich vom Festnetz anrufen lassen und das Gespräch mit der MobileApp angenommen. Diesmal etwas länger telefoniert:

einiges rot :frowning:

Diesmal auch einiges pascom -> Mobile mit ~680ms, das macht sich deutlich bemerkbar. In diesem Fall liegt es wohl am WLAN. Ist das Verhalten beim Echotest (*80) aus dem WLAN genauso [klar und deutlich sagtest du]?

Hier könnte eine Priorisierung im lokalen Netzwerk helfen, hängt aber stark von deiner Netzwerktopologie ab. Der Cisco unterstützt “Quality of service (QoS): Wi-Fi Multimedia and Traffic Specification (WMM TSPEC)” laut Datenblatt, ob man das aber konfigurieren muss kann ich nicht sagen.

Die externe Verbindung (ersten beiden und letzte Zeile) könnte auch besser sein, aber im Mittel konstant.

Zumindest tritt kein Packet loss auf, das zeigt schon eine stabile, aber eben evtl. langsame Verbindung.

Testweise könntest du eine pascom.cloud einrichten um zu sehen ob die Verbindung zu Peoplefone bzw. über den Mobile Client besser ist.

Gruß,
Rapha

WLAN ist die ganze Zeit deaktiviert, ich habe alle Tests über das 4G-Netz gemacht. Echo-Test über 4G klingt klar und deutlich. Das WLAN wollte ich erst mal komplett aus der Gleichung raus lassen.

Der Weg vom WAN ins LAN ist ja:

[Glasfaser-anschluss] -> [MikroTik-Medienkonverter RB260GS] -> [PFSense] -> [MD]

wobei MD und PFSense ja VM’s auf dem Proxmox-Host sind.Auf dem Medienkonverter habe ich geschaut. Dort gibt es kein QoS. Gibt es eventuell an der PFSense oder der Bridge-Konfiguration vom Proxmox noch Stellschrauben?

Ich habe heute Morgen ein Gespräch von extern (Festnetz) mit dem Tischgerät (Snom D375) angenommen - da ist der MobileHub ja dann raus - und dies sieht so aus:

also auch ein hoher Jitter-Wert MD->Peoplefone

Ich hatte ja einen Fehler beim Update von 7.19.02.R auf 7.19.03.R und die 7.19.04.R lässt sich nun auch nicht installieren. Siehe:

Könnte es Möglicherweise daher kommen?

Ich habe genau dasselbe Problem. Bei mir tritt das Problem allerdings nur bei Apple Geräten auf. Mit Android Geräten funktioniert es einwandfrei. Getestet im selben WLAN und LTE. Pascom 18.12.

Sicher nicht auszuschließen.

Wie weit ist denn Peoplefone entfernt bzw. was sagt ein traceroute (Peoplefone Howto, am besten von der Pascom aus)?

Du könntest sonst noch mit einem anderen Provider (Placetel, Easybell) testen. Die meisten Anbieter haben einen Basic/Free-Tarif oder einen Testzeitraum.

Der MikroTik RB260GS unterstützt kein QoS (nur SwitchOS), ab RouterOS L3 wird QoS unterstützt bzw. kann konfiguriert werden. Habe hier eine ausführliche Beschreibung (PDF) zum Thema VoIP und Mikrotik gefunden, da geht’s schon ins Detail.

Mit Proxmox und QoS sieht es auch eher dürftig aus, habe dazu nicht viel gefunden.

Unter PfSense nennt sich das Traffic Shaping, habe selbst eine pfSense im Einsatz aber keine konfiguration in Richtung QoS vorgenommen. Nur unsere Switche (Netgear M4300 und S3300) priorisieren den VoIP-Traffic entsprechend.
Jitter liegt bei uns meist so um 5ms mit kurzen Spitzen bis maximal 100ms (pascom -> Extern und Gegenrichtung), Intern immer <20ms.

Da der Echotest aber dieses Problem nicht hat vermute ich mal es ist die Verbindung zu Peoplefone und eher kein internes Problem.

Gruß,
Rapha

Auch ich habe sehr hohe Jitter Werte, wenn der Pascom Client genutzt wird.

Richtung (Jitter-Durchschnitt)

  • pascom Server -> extern (4 ms)
  • extern -> pascom Server (47 ms)
  • pascom Server -> mobil Client (799 ms)
  • mobil Client -> pascom Server (109 ms)
  • pascom Server -> desktop Client (108 ms)
  • desktop Client -> pascom Server (115 ms)

Diese Werte habe ich aus Grafana “Call Quality Overview”, den ich durch Filter erweitert habe, um mobil, desktop, extern und die Richtung filtern zu können.

Sobald der Pascom Client betroffen ist, sind die Jitter-Werte sehr hoch. Mobil wesentlich schlimmer, als desktop. Pascom zu SIP Provider ist eigentlich immer in Ordnung, wobei extern zu pascom Server auch etwas besser sein könnte.

Es spielt eigentlich keine Rolle, ob WLAN, LAN, LTE, die Werte sind nahezu identisch. Mit QoS Optimierungen im Büro ist es zumindest dort etwas besser geworden (Schnitt von 200 auf 100 ms herunter), aber dennoch sind die Jitter-Werte zu hoch.

Die Sprachqualität ist dabei recht unterschiedlich. Bei vielen Gesprächen ist sie okay, bei manchen aber doch auffällig schlecht.