Pascom Client Fehler 87 bei Start in Remote Desktop Sitzung

Hallo,

unter Windows 10 ist der Pascom Client installiert und funktioniert wie erwartet.
Meldet sich der gleiche Benutzer über RDP an diesem Computer an und startet den Pascom Client erscheint die Fehlermeldung “LoadLibrary failed with error 87: Falscher Parameter.”.
Ist das verhalten bekannt und gibt es einen Workaround?

Viele Grüße

Igor

Hallo @irennert,

nein, das ist nicht direkt bekannt. Könntest du die verwendete Umgebung / Hardware etwas genauer beschreiben? Insbesondere die installierten Grafikkarten im System wären interessant.

Sind da alle Treiber aktuell? Verhält sich die v67 Beta genau so?

Grüße,
Jan

Hallo @jlorenz,

OS ist Windows 10 Pro 2004, Intel HD Graphics und Radeon HD 5400 sind beide mit gemäß Windows Update aktuellen Treibern in Benutzung. Das Problem besteht auf diesem System schon seit vielen Monaten, vermutlich seit der ersten Installation im März oder April.
Mit der v67 besteht der Fehler unverändert.

Viele Grüße

Igor

Hallo @irennert,

das hat evtl. mit den beiden Grafikkarten zu tun, spontan kann ich den folgenden Link finden, der vielleicht helfen könnte: https://superuser.com/questions/1516486/windows-10-loadlibrary-failed-with-error-87-on-remote-desktop-session

Ich kann aber keine Gewähr dafür übernehmen dass die Workarounds funktionieren bzw. keine Probleme verursachen - versuch ist also auf eigene Gefahr. :wink:

Grüße,
Jan

Hallo @jlorenz,

bei deaktivierter Radeon-Grafikkarte tritt das Problem nicht auf, aktuelle Treiber beheben das Problem nicht. Auch die im Link genannten Varianten helfen nicht.
Mit dieser Hardware wird das Problem wohl nicht mehr zu lösen sein.

Viele Grüße
Igor

Hallo @irennert,

dann ist das definitiv auf den Grafiktreiber zurückzuführen. Ein Versuch wäre noch, den Render Modus unter Einstellungen > Erweiterte Einstellungen > Render Modus zu ändern. Angle (Warp) oder OpenGL Software deaktivieren Hardwarebeschleunigung, das wäre einen Versuch wert.

Grüße,
Jan

Hallo @jlorenz,

hat leider auch keinen Einfluss auf das verhalten gehabt.

Viele Grüße

Igor

Hallo zusammen,
es passt nicht ganz hier rein, aber bei einer RDP auf diversen Rechnern beobachte ich auch häufig diese Meldung beim Starten vom Pascom Client.

image

Render Modus steht eigentlich immer auf Auto.

Wenn der Client gestartet wurde und erst danach eine Verbindung per RDP hergestellt wurde, dann läuft er reibungslos.

Gibt es eine Möglichkeit, über eine Start Variable oder so, den Render Modus auf Software umzustellen? Oder gibt es einen “RDP Modus” für die Pascom App.

Das passiert nur in Windows 10 RDP Sitzungen bisher. Aber auch schon länger. Wird also 1909 und 2004 Win 10 betreffen.

Grüße
Seppos

Ich kann das bestätigen, ist bei mir auch so, bzw schon “immer” so gewesen. Melde mich oft per RDP vom Home Office auf meinem PC in der Firma an. Dort ist der Pascom Client im Autostart dann kommt diese Meldung.

Ich habe einen Fujitsu PC Win10 1903 mit einer AMD Radeon HD 7530

grafik

Hallo zusammen,

@T.Gebler: Die “Fehler 87” Probleme scheinen im Allgemeinen nur mit älteren Radeon Karten aufzutreten. Ich vermute das ist ein Treiber-Bug. Da ein Ändern des Render-Modus offenbar nicht hilft, glaube ich nicht das wir hier noch viel tun können.

@seppos: Tatsächlich erkennt der Client ob er innerhalb einer RDP Sitzung läuft und passt den Rendermodus entsprechend an. Magst du mal prüfen, ob der Client, wenn innerhalb einer RDP Sitzung gestartet, Unter Einstellungen > Erweiterte Einstellungen > Systeminformationen im Abschnit OS auch die Info `(Remotedesktop / Terminal Server) ausgibt?

Grüße,
Jan

Hey Jan,

an einem meiner Rechner macht er es.

Wenn der Client bereits geöffnet ist, dann springt er nicht um. Dann sieht es so aus:
image

Wenn der Client dann zu ist kommt entweder die Meldung aus meinem letzten Post. Oder aber, an diesem Beispiel, startet der Client. Und es wird RDP angezeigt.

Bei dem PC, an dem der Client nicht startet, ist auch eine Radeo Graka drin.
Sollte aber per RDP nix ausmachen, oder?!

LG
Seppos

Hallo @seppos,

doch, das macht durchaus einen Unterschied. Beide Fehlermeldungen (Error 87 und der kaputte OpenGL Kontext) beziehen sich auf sehr Grafiktreiber spezifische Dinge.

Welche Grafikkarte ist denn verbaut?

Grüße,
Jan

Moin.

Ich habe hier im Büro ein Beispiel.
Mein PC hat eine AMD FirePro W4100 verbaut.
Da klappt es nicht.

Dann habe ich nochmal getestet an einem anderen PC mit einer NVIDIA NVS510, aber da klappt es.
Ich meine mich zu erinnern, dass es bei dem PC auch nicht ging, kann aber auch nur Einbildung gewesen sein…

Grüße

Hallo zusammen,

ja, für mich sieht das nach einem AMD Treiberproblem aus, das scheinbar hauptsächlich mit sehr alten Karten (Radeon HD5400: 2009, Radeon HD 7530: 2012, FirePro W4100: 2015) innerhalb von RDP-Sitzungen auftritt.

@seppos: Eine Idee habe ich noch, die man versuchen könnte. Dazu bräuchte ich aber die SupportInfo.zip. Könntest du mir diese via PN zukommen lassen?

Grüße,
Jan

Hallo @seppos,

danke für die Supportinfo. Versuche bitte folgendes. Füge bitte am Ende der Datei %LOCALAPPDATA%\pascom Client\windows-opgengl-buglist.json folgenden Abschnitt an:

{
           "id": 19,
           "description": "Disable DesktopGL on AMD FirePro W4100 devices",
           "vendor_id": "0x1002",
           "device_id": [ "0x682c" ],
           "os": {
               "type": "win"
           },
           "features": [
               "disable_desktopgl"
           ]
}

Da es JSON ist, ist es wichtig, am vorherigen Eintrag noch ein Komma anzufügen :wink:

Ggf. den Inhalt mitttels https://jsonlint.com/ prüfen, ansonsten funktioniert die Blacklist nicht. Wenn das aktiv ist, sollte es die Verwendung von OpenGL auf dieser Karte dauerhaft deaktivieren. Falls disable_desktopgl nicht hilft, kann man ggf. noch disable_angle anfügen (Gibt Beispiele hierfür in der Datei) und so reines Software-Rendering erzwingen. Bei jedem Versuch natürlich den Client neu Starten.

Klappt es dann mit dem RDP Zugriff?

Falls das alles nichts bringt, gibt es noch die Möglichkeit, in den erweiterten Einstellungen den Rendermodus auf Software festzulegen - diese Option deaktiviert aber auch den Video-Support.

Grüße,
Jan

Hey Jan,
danke für die Datei und den Hinweis mit dem Komme. :slight_smile:
Habe ne Sekunde gebraucht, bis ich das Komma an die richtige Stelle gesetzt habe.

Funktioniert leider nicht.

Habe “nur” “disable_desktopgl” und auch zusätzlich “disable_angle” versucht.
Startet nicht:

image

Bei beiden,also:
“features”: [
“disable_desktopgl”,
“disable_angle”

startet er auch lokal nicht mehr.

Also?! Neue Graka?

Ich habe es jetzt auf “Software” umgestellt, damit startet er auch in einer RDP Sitzung

Grüße
Seppos

Hallo @seppos,

Wenn “Software” Funktioniert, könntest du dann bitte mal mit Angle, Angle (D3D9) oder Angle (D3D11) probieren?

Evtl. kann man so um das Treiberproblem herum arbeiten und trotzdem Video-Support haben.

Grüße,
Jan

Hey @jlorenz,

ich habe getestet.

Alle ANGLE funktionieren. Inklusive ANGLE Warp.

Habe mich nun für Angle Warp entschieden :slight_smile: Ist der coolste Name!

Auch wenn es nichts mit
f(x) = x ^((10/3) / (1 - (x/10)^(( 91,28 / (10-x)^0,27)))) (Quelle: https://www.arndt-bruenner.de/mathe/Allgemein/warp/warp.htm)
zu tun hat.

Grüße
Seppos

Hallo @seppos,

danke für das ausführliche Testen und das Feedback. Daraus kann ich folgende Schlüsse ziehen:

  1. OpenGL Support innerhalb einer RDP Sitzung ist Treiberseitig auf eine andere Art Buggy als ohne RDP
  2. Standardmäßig OpenGL Software zu aktivieren wenn eine RDP Sitzung aktiv ist, ist keine allgemeingültige Lösung, wegen Punkt 1. - Es ist schlauer die Devices individuell auf einen Blacklist zu setzen
  3. ANGLE hilft

Ich nehme hier ein Bugticket im Client auf um die selektion des Render-Backends an dieser Stelle zu verbessern.

Als hinweis noch für dich: Angle (Warp) ist ein Software-Renderer, d. h. je nachdem wie viele User auf dem Terminal Server sind, könnte es zu CPU Engpässen kommen. D3D9 und D3D11 hingegen sind Hardware-Beschleunigt. Angle ohne suffix versucht automatisch das am besten passende Backend zu finden.

Grüße,
Jan