Schriftgröße des pascom Clients skaliert auf 4K Display nicht mit (= Schrift ist winzig klein)

Hallo zusammen,

wenn man den pascom Client auf einem 4K Display mit voller Auflösung (3840 x 2160 px ) startet, skaliert die Schriftgröße (und genau genommen der ganze Bildschirmaufbau) nicht mit. Die Schriftgröße ist so winzig klein, dass man es beinahe nicht mehr lesen kann.

Alle andere getesten Anwendungen skalieren 1a, d.h.: sie sehen proportional genau so aus, wie auf Full HD bspw., nur dass alles feiner aufgelöst ist, während der pascom Client zwar das Format des Displays füllt, aber alle Schrift ultra klein ist.

Braucht man 4K?
Wir betreiben 4K Displays in unserem Konferenz- und Showroom. Also genau da, wo wir Kunden pascom präsentieren und die Kunden überzeugen wollen.

Umgebung: Linux Mint

Da ausnahmslos alle Anwendungen, die wir getestet haben (incl. aller Browser, Thunderbird, LibreOffice u.v.m.), richtig skalieren, gehe ich davon aus, dass der Bug nicht so schwer zu beheben sein dürfte.

Es wäre hilfreich, wenn der pascom Client absehbar auch richtig skalieren würde.

Viele Grüße,
Ansgar Licher

Hallo @AnsgarLicher,

danke für die Rückmeldung.

um das Problem einzuschränken: Passiert das, auch wenn Du an den 4K Monitor ein macOS oder Windows anklemmst?

LG
Mathias

Ich bin auf MacOS mit 2x4k Bildschirm, bei mir ist die Skalierung i.O.

Hallo Mathias,

leider haben wir keine Mac OS Systeme in Reichweite; Windows haben wir bestenfalls auch nur als Test-VMs, jedoch nicht produktiv im Einsatz. Daher kann ich hier leider keine qualifizierte Rückmeldung geben.

VG,
Ansgar Licher

Hallo @AnsgarLicher,

HiDPI Skalierung ist unter Linux standardmäßig abgeschaltet - da gab es Probleme.

Versuche einmal die Umgebungsvariablen aus diesem Thread zu setzen.

Hilft das?

Grüße,
Jan

PS: Notwendiger Disclaimer: Linux Mint wird von uns nicht offiziell Supported…

Hallo @AnsgarLicher,

hilft das Setzen der genannten Umgebungsvariablen?

Grüße,
Jan

Hallo Jan,

danke der Nachfrage. Hab es mal gerade auf dem großen Display nachvollzogen.

Kurz gesagt: Ja, es ändert sich was, aber es wirkt sich nicht auf die Schriftgröße im Hauptbereich des Fenster aus (Telefonbuch, Jounal, …).

Ich habe drei Screenshots angefertigt, die das einigermaßen zeigen. (Alle sind auf dem 4K Screen hergestellt).
Der 3. Screenshot zeigt den pascom Client ohne die Settings, dafür zusätzlich einen Ausschnitt aus nemo, wo die Schrift (wie gewollt) so mitskaliert, dass das Gesamtbild passt (beim pascom Client ist die Schrift im Hauptbereich (Telefonbuch) dagegen immer noch winzig).

pascom Client ohne Settings:

pascom Client mit den vorgeschlagenen Settings:

pascom Client und Nemo:

Es ist also besser, aber noch nicht so, wie erwartet.

Viele Grüße,
Ansgar Licher

Hallo @AnsgarLicher,

ich habe ein Ticket dafür aufgenommen, wir werden uns dieses Themas annehmen.

In der Zwischenzeit: Auf welchen Wert ist die Skalierung denn in den Betriebssystem-Einstellungen gesetzt? 200% (oder 2x), 300% (3x)? Ein krummer Wert?

Ggf. hilft es ja auch die letzte Umgebungsvariable etwas zu verändern, z. b.

export QT_SCREEN_SCALE_FACTORS=3

Grüße,
Jan

Hallo Jan,

der Skalierungsfaktor wirkt (siehe auch die Screenshots oben). Die gesamte Skalierung des Clients ändert sich. Aber leider bleibt die Schrift (auch im Favoritenbereich übrigens) davon unberührt und winzig (wie bisher)!

Die Skalierung in den Betriebssystem-Einstellungen muss ich noch nachsehen. (Die dürfte einen glatten Standardwert haben). Das melde ich noch nach.

Viele Grüße,
Ansgar Licher

Hallo @AnsgarLicher,

danke für das Feedback. Die Probleme sind in den Frameworks die wir verwenden immer noch vorhanden, ein einfaches aktivieren des HiDPI-Supports zerschießt das ganze Layout unter Linux.

Wir arbeiten aber an dem Thema und in naher Zukunft ist da ein Update geplant das die Situation vielleicht verbessert - das wird aber noch etwas dauern.

Konntest du den auf deinem System konfigurierten Skalierungsfaktor schon in Erfahrung bringen?

Grüße,
Jan

Hallo,

bin auf den Beitrag gestoßen und habe es gerade mal getestet. System:


Der Ubuntu-Installer setzt die Skalierung bei dieser Auflösung automatisch auf 200%
Die Umgebungs-Variabeln:

export QT_SCALE_FACTOR=1
export QT_AUTO_SCREEN_SCALE_FACTOR=0
export QT_SCREEN_SCALE_FACTORS=2

habe ich vor dem Start gesetzt. Ergebnis:

vielleicht hilft es ja.

Viele Grüße
Sven

Hallo @pixel24,

vielen Dank fürs Testen. Ich habe ein paar Experimente gemacht, leider ist der HiDPI-Support momentan unter Linux im Client nicht zufriedenstellend aktivierbar.

Wir sind aber an dem Thema dran, und ich werde mich melden sobald neue Erkenntnisse gibt.

Grüße,
Jan

Ja, diverse Programme habe da noch Probleme. Auf mein ZBook (mit dem ich getestet habe):

  • Gimp: Werkzeugkästen skalieren nicht mit
  • Moneyplex: Kaum bedienbar wegen der Schrift-Skalierung
  • Pinta: Werkzeugkästen skalieren nicht mit

… und das sind nur die die ich immer nutze. Es scheint also nicht so einfach zu sein Programme daran anzupassen. Die Tatsache das jedoch viele Programme damit umgehen können gibt Hoffnung :slight_smile: