Yealink T46G ausserhalb des LAN's der Mobydick

german
endpoint

#1

Hallo,

Ich habe zum testen ein Yeahlink T46G gekauft und versucht es an die Mobydick (7.14) anzubinden. Das funktioniert super, solange ich das Telefon ans von der Telefonanlage verwaltete VLAN hänge.
Ich wollte es aber auch von ausserhalb testen, entsprechend habe ich es in ein anderes Netzwerk gehängt und versucht zu provisionieren. Ich habe es nicht hingekriegt.

Erster Versuch war mit dem Provisionierungslink. Irgendetwas hat sich getan, denn ich konnte mich nachher nicht mehr auf der Weboberfläche des Telefons einloggen, aber das war es dann auch.
Dann habe ich versucht die Kontodaten manuell einzutragen und dabei alle möglichen Kombinationen aus Benutzername, Passwort und Registrierungsname (Sowohl des Telefons als des Benutzers dem das Telefon gehören soll) ausprobiert, ohne Erfolg. Welches wäre da die richtige Kombination?
Auf der Firewall habe ich die Ports 5060, 10000-20000 (jeweils UDP und TCP) sowie 80 und 443 (TCP) auf die Telefonanlange weitergeleitet. Ich habe auch keine geblockten Verbindungen im Log gesehen.
Auf der Telefonanlage selber habe ich es auch damit versucht, die “externip” und “nat” Optionen zu setzen, leider hat das auch nicht geholfen.
Was mache ich hier falsch?

Gruss,

plcaa


#2

Hallo plcaa,

der Account (Benutzername / Passwort) des mobydick-Benutzer entspricht **nicht ** den Peer-Daten des Telefons - das kann also nicht funktionieren.

Warum möchtest du das Telefon außerhalb deines Telefonnetes (VLANs) betreiben?

Grüße,
Jan


#3

Hallo Jan,

ich würde mich hier gern mal dranhängen, da ich ein gleiches Vorhaben nur mit Snom 720 habe.
Ein aus Sicht der MobyDick entfernter Standort, via VPN verbunden. Somit anderes Subnetz, eigener DHCP und so weiter. Wie binde ich korrekt ein entferntes Snom-Telefon ein? Bisher ist mir das nur mit “IP-Telefon: Hersteller beliebig oder Softphone” gelungen.

Freue mich auf Rückmeldung.

Beste Grüße
Sebastian


#4

Hi Sebastian,

konfiguriere den DHCP Server des entfernten Standortes so, dass dieser die via DHCP Option 66 an den Telefonen, die Adresse der MobyDick gibt. Siehe hierzu -> https://www.pascom.net/de/dokumentation/mobydick/server/netzwerk-konfigurieren/#windows-dhcp-server-nutzen

Grüße

Maik


#5

Hallo Maik,

vielen Dank für deine schnelle Rückmeldung.
Genau das hatte ich so versucht, das Gerät wurde auch in der entfernten MobyDick angelegt, jedoch konnte die MobyDick anschließend nicht mit dem Telefon kommunizieren und zum Beispiel einen Neustart ausführen nachdem ich ein User damit verknüpft habe. Firewall-Regeln zwischen den Standorten sind natürlich alle entsprechend angepasst.

Beste Grüße
Sebastian


#6

Hallo Sebastian,

hast Du das Telefon einmal auf Werkseinstellungen zurück gesetzt (vom Telefon aus). Die Snom Telefone sind was die Settings angeht manchmal etwas zickig.

Grüße Maik


#7

Hallo Maik,

ja, via: Erweitert > Update > Zurücksetzen.
Welche Rolle spielen die Felder “Feste IP-Adresse” und “NAT aktiviert” in der MobyDick Geräteverwaltung?

Beste Grüße
Sebastian


#8

Hi Sebastian,

Welche Rolle spielen die Felder “Feste IP-Adresse” und “NAT aktiviert” in der MobyDick Geräteverwaltung?

Keine Ahnung…

Grüße

Maik


#9

Hallo @maik, @sebastian,

bei dem seltenen Ereignis, dass @maik mal “keine Ahnung” hat helfe ich gerne aus:

Wenn Du unseren DHCP nutzt machen wir für dieses Telefon eine IP-Reservierung.

Setzt für dieses Telefon die SIP-Option “nat”. Das brauchst Du wenn sich das Telefon hinter einem NAT (aus Sicht der Anlage) befindet.

LG
Mathias


#10

Hallo Maik, hallo Mathias,

danke für euer Feedback und alles Gute für das neue Jahr.
Bei dem Provisionierungsvorgang in einem via VPN verbundenen Subnetz wird das Telefon in der MobyDick angelegt, jedoch nicht mit der IP-Adresse des Telefons, sondern mit der Gateway-Adresse des entfernten Subnetzes. Und das obwohl an dieser Stelle kein NAT stafffindet. Dieses Verhalten führt dann dazu, dass die MobyDick nicht mit dem Telefon “sprechen” kann um zum Beispiel einen Reboot durchzuführen nachdem ein Benutzer dem Telefon zugeordnet wurde.

Zum besseren Verständnis:
Netz Standort A: 192.168.1.0/24
Gateway: 192.168.1.1
IP der MobyDick: 192.168.1.10

Netz Standort B: 192.168.100.0/24
Gateway: 192.168.100.1
IP des Snom 720: 192.168.100.26

In den DHCP-Optionen für das Provisionieren ist am Standort B die MobyDick an Standort A hinterlegt. Nach dem das Telefon an Standort B fertig gebootet hat, gibt es in der MobyDick an Standort A ein neues Gerät mit der IP-Adresse: 192.168.100.1 obwohl in dem VPN-Tunnel kein NAT stattfindet.

Habt ihr hierfür eine Erklärung?

Beste Grüße
Sebastian


#11

Hallo @sebastian,

klar :wink:

Also: Generell erscheint das Telefon immer in der Liste wenn die DHCP Option richtig gesetzt ist. Dann meldet sich das Telefon am Server and und übergibt per HTTP seine MAC-Adresse und zieht sich die Konfig. Das klappt ja bei Dir auch. Es ist richtig, dass die pascom bei NAT immer die zuletzt gesetzte SNAT Adresse sieht und dass hier keine Fernsteuerung des Telefones möglich ist.

Wenn Du also auf der pascom die 192.168.100.1 siehst verbiegt irgendwas die Quell-Adresse.

Einfach Test: Kannst Du von der pascom aus die 192.168.100.26 pingen?

Falls ja schau doch mal in das Log des Apaches tail -f /var/log/apache2/access.log und schalte dann das Telefon ein. Was sieht der Apache als Quell-IP? Die 192.168.100.1? Dann ist es 100% irgend ein NAT.

LG
Mathias