Easybell und PJSIP

Hallo zusammen,
durch die Umstellung auf Pascom 19 sind ja die Amtseinstellungen angepasst worden.

Dabei sind die in den SIP-Optionen eingetragenen Parameter alle soweit möglich konvertiert worden.
Allerdings sind zwei Optionen dabei, die es nicht in die neue Version geschafft haben:

; udptl=yes
; t38pt_udptl=yes

Wie setze ich die denn unter PJSIP korrekt? Problem ist nämlich, dass das Faxen mit Hilfe eines HT-802 nicht mehr funktioniert. Vllt. muss ich die aber auch beim Endgerät setzen?

LG
Michael

Hallo Michael,

die Optionen sollten so aussehen, gemäß https://wiki.asterisk.org/wiki/display/AST/Asterisk+16+Configuration_res_pjsip:

endpoint/t38_udptl=yes

Habe selbst ein HT802, allerdings noch nicht getestet. Man könnte noch mit der error correction spielen:

endpoint/t38_udptl_ec=redundancy

Gruß,
Rapha

1 Like

Hallo @rapha,

danke für den Hinweis. Das werden wir checken und ggf. einarbeiten.

LG
Mathias

Danke @rapha

Damit funktioniert mein Fax zwar immer noch nicht, aber das wird noch andere Ursachen haben.

Wenn ich im HT-802 T.39 aktiviert lasse (Standard) gibt es nach dem ersten CNG-Signal immer ein Rauschen. Stelle ich um auf Passthrough, ist das Rauschen weg und ich hören zumindest eine CNG-Sequenz aber keine zweite mehr und in der CLI gibt es dann ein RTP-Timeout nach 30 Sek.

Line Echo Canceller und Network Echo Suppressor sind ebenfalls dekativiert inzwischen.

Die PJSIP-Optionen habe ich nun sowohl beim Amt eingetragen als auch bei Endgerät.

Gruß
Michael

@Mathias Im Zusammenspiel Pascom 19 und HT-802 passt es noch nicht so ganz.

Ich habe es mit den diversen PJSIP T.38-Optionen probiert und auch mit diversen Einstellungen am HT-802. Es gibt immer ein RTP-Timeout.

Dann habe ich den HT-802 direkt mit Zugangsdaten von Easybell gefüttert und siehe da, das Faxen läuft auf Anhieb prima.

Das mal so zur Info.

LG
Michael

Das kann ich bestätigen, habe auch diverse t38 Optionen getestet, jesesmal tritt der Timeout auf.

Wäre t38_udptl_nat noch eine Möglichkeit?
Hier müssten dann freigeschaltete Ports genutzt werden, soetwas wie

endpoint/t38_udptl_nat=yes
global/udptlstart=4000
global/udptlend=4999

Werde nochmal weiter testen.

Gruß,
Rapha

@rapha
Ich belasse es in meinem Fall für den Moment bei einer direkten Registrierung der Faxdurchwahl. D.h. dass ich bei Easybell für die Faxdurchwahl einen eigen SIP-Account angelegt haben und damit dann den HT-802 gefüttert habe.

Die ganzen pjsip-Parameter haben (zumindest wenn man Sie im Amt einträgt) zur Folge gehabt, dass das Amt nicht mehr erreichbar war.

Ist die Pascom Entwicklung dabei dieses Problem zu lösen und fließt das in die 19.01 er ein?

@Noses: Hast du viel am ATA angepasst? Könntest du vielleicht eine funktionierende Config exportieren, exklusive der Easybell relevanten Daten versteht sich :wink:

Danke!

THOMAS

@EDV-Service Nein, da ist nichts angepasst worden. Auslieferzustand und dann für einen der analogen Ports die Zugangsdaten vom Cloud-Account eingetragen und das war dann schon alles.

LG Michael

Alles klar, danke!

THOMAS

Hi!

Ich habe nun eine Cloud 19.02 mit einem HT802. Ich hatte erst eine generisches SIP Gerät angelegt und die Anmeldedaten im ATA beim FXS Port eingetragen, Gerät war registriert, aber auf keiner Seite ist etwas zu hören gewesen. Beim Anruf nicht einmal auf A Teilnehmer Seite ein Freizeichen.

Dann habe ich noch probiert so vorzugehen, wie man es normal macht. Gateway in Anlage anlegen, URL in ATA, da provisionieren ja nicht geht habe ich nach dem Neustart vom ATA noch die SIP Anmeldedaten im ATA eingetragen. Nun registriert sich das Gerät nicht.

Was mache falsch? Vielleicht ein Tip für mich?

LG THOMAS

P.S.: Welche Firmware ist auf deinem ATA?

So, ein Update. Neuere Firmware aufgspielt und nach Werksreset den ATA mit den Benutzerdaten befüllt, ATA ist registriert, man kann intern und extern auf der Nebenstelle anrufen und sprechen. Abgehend telefonieren funktioniert weder intern noch extern. Es kommt nur ein “tut tut tut tut”.

Ich gucke mir morgen mal die Daten von einem funktionierendem ATA ab und trage das Analog auf dem Problemkind ein. Dann teste ich noch einmal und berichte…

LG THOMAS