TAPI friert ein

Hallo zusammen,

seit der Installation des neuen TAPI Treiber, der für die Version 20 benötigt wird, hängt sich auf allen Rechnern regelmäßig der TAPI Dienst auf und muss über den Taskmanager gekillt werden. Ein einfaches neu starten über Dienste bzw. den PC neu starten funktioniert nicht.

Hat jemand auch dieses Problem?

Mir haben Kunden vereinzelt davon berichtet, ich konnte es allerdings nicht reproduzieren. Meist hat der Neustart des Telefonie-Dienstes geholfen.

Hallo habe das selbe Problem auch bei 2 Kunden.

Gruß Jörg

Hat jemand schon was neues dazu?

Habe das Problem mittlerweile bei immer mehr Kunden. Aktuelle Info wäre mal gut :slight_smile:

Ich reih mich mal ein. Ich habe das “dauernd” bei Kunden. Wie @noses schon sagt hilft meist der Neustart des Dienstes “Telefonie”. Manchmal ist aber auch der Dienst “Telefoniedienst” aus, dann lässt sich der Dienst “Telefonie” nicht neu staten. Immer wieder hilft das aber alles nicht und ich muss den PC neu starten, die TAPI deinstallieren und wieder neu installieren, PC bzw. Dienste neu starten und dann geht es meist wieder ein paar Tage. Ist bei leider ein Dauerthema :frowning: Ist halt legacy Technik, die dringend weg muss.

Hallo zusammen,

wir können auf unseren Systemen bisher kein solches Verhalten reproduzieren.
Zur weiteren Analyse und Fehlersuche benötigen wir allerdings Logs. Hier wird beschrieben wie diese aufgezeichnet werden können.

Die Logs dann entweder hier per PN an mich oder (besser gleich) den Weg über den Support gehen.

Gruß
Juri

Ich hab das schon mehr als ein Mal mit dem Support bearbeitet. Oft ist es so, dass das Problem von alleine wieder weg ist bis sich jemand meldet :slight_smile: Die beschriebenen Prozeduren habe ich alle vom Support.

Ticket# 5949041
Ticket# 5948575
Ticket# 5946991
Ticket# 5947654

Das aber alles nur der Vollständigkeit halber. Hab mich dran gewöhnt und glaube nicht, dass es echte Abhilfe gibt, da ich meine, dass das eher ein Windows-Problem als ein Pascom-Problem ist. Bei meinem Problem-Kunden habe ich 10 PCs, zwei machen dauernd Probleme. 3 manchmal und der Rest so gut wie nie …

Bei uns hat es halt exakt mit der neuen pascom Version angefangen. Daher glaube ich nicht so sehr an ein Windows Problem. Das andere mehr und andere weniger betroffen sind, ist bei uns auch der Fall wobei ich auch glaube das es vielen einfach nicht auffällt, denn die die bei uns intensiv betroffen sind, sind auch diejenigen die viel telefonieren.

Da gehe ich noch nicht mit. Es gibt ja durchaus andere Hersteller von Anlagen und damit auch von TAPI-Treibern, die ebenfalls unter WIN10 oder höher laufen. Auffällig ist schon, dass es bei solchen Anlage dann keine Rückmeldungen von Kunden gibt.

Fest steht aber auch: Es lässt sich nicht reproduzieren, wobei der Energiesparmodus “gefühlt” eine Rolle spielt. Aber was sind schon Gefühle. Wir sind hier ja nicht im Kino.

Das könnte aber durchaus eine Richtung sein, denn dieses Gefühl habe ich auch mit dem Energiesparmodus.

Komisch ist wirklich, dass es erst mit der neuen TAPI Version 7… kam. Vorher hatten die Kunden gar keine Probleme. Daher würde ich das Windows Thema auch eher ausschließen. Ich konnte aber auch noch keine Ähnlichkeiten finden bei den Kunden, woran es liegen könnte. Bei mir hilft zu 99% der Neustart des Telefonie Dienstes. Es werden nur immer mehr mit diesem Problem und da kann der Neustart des Dienstes ja nicht die Lösung sein.

2 Likes

Seit wann gibt es dann die v7? Ich habe die Probleme seit ca. Oktober/November 2020.

Die Sache mit dem Energiesparmodus werde ich morgen überprüfen und wieder berichten.

Ergebnis: Energiesparmodus steht bei allen Problem-Arbeitsplätzen auf “nie”. Für mich besteht somit kein Zusammenhang damit.

Hallo,
also ich muss auch sagen das gefühlt seit dem v7 TAPI Treiber etwas ab und zu hängt.
Zur Integration in unser ERP benutzen wir ESTOS. Das hat vorher eigentlich tadellos geklappt, vielleicht alle 5-6 Monate musste der PC der das macht mal neu gestartet werden.

Nun ist es des Öfteren vorgekommen dass die TAPI Anbindung nicht mehr reagierte - hab dann in erster Line mal ESTOS neu gestartet, aber das Problem war weiterhin - seit dem starte ich wenn das ist immer den ganzen Rechner (und damit den Pascom TAPI Treiber) neu und es funktioniert wieder.
Einen richtigen Auslöser konnte ich bisher auch nicht festmachen. Meine Lösung besteht jetzt darin diesen PC täglich neu zu starten - seit her keine Probleme mehr.

Gibt es denn den TAPI v7 Treiber auch in einer stabilen Version (ich meine damit dass der zum Download angebotene Treiber ja noch mit “Beta” gekennzeichnet ist…

Gruß
Christoph

Also wir haben, seit dem wir auf p20 sind, unsers test estos herunterfahren, weil er immer wieder Probleme gemacht hat
Was mir damals ausgefallen ist: immer wenn pascom ein Update für die Anlage installiert hat, war die tapi Verbindung danach weg :frowning: evtl ist das ein Ansatz?

Hallo zusammen,

die TAPI v7 hat im Vergleich zur v6 eine signifikante Überarbeitung erfahren, um zur pascom20 kompatibel zu werden.

In unserer Testumgebung (u. a. mit Outlook und PhoneSuite) läuft die v7 stabil und bisher sind alle Debugging-Versuche entweder aufgrund von Bedienfehlern oder “es geht plötzlich doch” im Sande verlaufen.

Deshalb folgende Bitte

  1. Stellt sicher das die aktuelle Version der TAPI installiert ist. Die aktuelle Version kann immer hier heruntergeladen werden. (Wichtig: Die Tapi aktualisiert sich nicht automatisch selbst!)
  2. Falls es damit immernoch nicht klappt, führt die hier beschriebenen Schritte zum Debugging durch: TAPI Client Installation - wichtig ist vor allem das DebugView Log
  3. Wenn ihr Logs von einem Fehlverhalten habt, sendet bitte diese Logs zusammen mit einer Beschreibung des Fehlers und möglichst genauen Zeitangaben via PN an mich

Vielleicht kommen wir so weiter.

Grüße,
Jan

Hallo zusammen,

ein kleines Update zum Thema: wir konnten hier mittlerweile eine Optimierung implementieren die das Problem vermutlich behebt.
Der Fix befindet sich noch intern im Testing.
Falls Interesse besteht die Version bereits vorab selbst zu testen, besteht die Möglichkeit über den Support zu beziehen.

lg
Juri

3 Likes

Hallo zusammen,

die neue Version steht ab sofort zum Download bereit, wir haben soeben den Link auf der pascom Homepage aktualisiert.

Bitte beachten, dass die TAPI sich nicht selbständig aktualisiert und hier das Update von Hand vorgenommen werden muss!

lg
Juri

1 Like